cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ed Staub" <est...@mediaone.net>
Subject RE: Alternative to cocoon ?
Date Mon, 21 Aug 2000 16:51:42 GMT
This sounds likely to me.
Paul may have run afoul of a bad classloader implementation.

> It returns null, even if the logicsheetName (whose value is
'xsp-java.xsl')
> correspond to a file present in the jar file, in another branch.
What do you mean by "in another branch"?
It should be in org.apache.cocoon.processor.xsp.

Here's a few wild suggestions:

Try extracting the jar into a directory tree, and change the classpath to
point at the directory tree instead.  It's possible that the classloader has
a problem with resources in jarfiles; I've seen it before.

If that doesn't work, leave Cocoon extracted in the tree, and hack the code
at the
	getResourceAsStream(logicsheetName)
to put in a
	System.out.println("URL=" + getResource(logicsheetName)),
and see where it thinks the file should be.  (I don't think this will work
if it's in a jar file; that's why you should leave it extracted.)

-Ed Staub

-----Original Message-----
From: mikech@riverbendsystems.com [mailto:mikech@riverbendsystems.com]
Sent: Monday, August 21, 2000 11:35 AM
To: cocoon-users@xml.apache.org; Paul Terray
Subject: Re: Alternative to cocoon ?


Hi,

Your problem may be that you are using NES's internal servlet engine. In
the recent past this has been real cr*p; they were still using JDK 1.7.
However, I'm not sure about the current state.

** At any rate, I would suggest using a separate servlet engine. You
want something that uses a native NSAPI plugin. Commercial products
include JRun (see next paragraph) and Weblogic. An alternative to
commercial products is Apache's Tomcat, but I'm not sure they offer
native NSAPI plugin support. There are several other alternatives, and
you may get some advice from the group as to what works and what does
not.

NOTE TO GROUP: I have had problems getting cocoon to work using JRun
3.0. There was a HOWTO posted to the list describing Cocoon / JRun
integration for JRun 2.0. I tried HARD to make it work for 3.0, but the
differences in DOM libraries made it impossible. I finally got it
working with Weblogic 5.1. *** I would be very interested in hearing
from someone who has gotten Cocoon working with JRun 3.0.

Hope this helps,
Mike

Paul Terray wrote:
>
> At 09:51 21/08/00 -0400, you wrote:
> >Paul,
> >You might get more useful responses if you can provide some more detail;
> >"it seems it does not install correctly" is not a lot to go on.
> >-Ed Staub
>
> Well, I posted several mail on this already, on this list and
cocoon-devel,
> without any answers (probably holydays).
>
> Here is my original posting on cocoon-devel :
> Hi,
> I badly need your help, as I must make this working.
>
> I am trying to install Cocoon on iPlanet Enterprise Server 4.1
(ex-Netscape
> Server). There is an error happening for Cocoon 1.7.2, as welll as 1.7.4.
>
> When launching Cocoon (by hooking the servlet to the URL
> <myhost>/Cocoon.xml), I get the following error :
> Publishing Engine could not be initialized.
> java.lang.RuntimeException: Error while initializing XSP engine:
> java.lang.Exception: Resource 'xsp-java.xsl' could not be found.
> at
org.apache.cocoon.processor.xsp.XSPProcessor.init(XSPProcessor.java:161)
>
> After having a look at the code, it appears that the following line is the
> culprit :
> InputStream logicsheetInputStream =
> this.getClass().getResourceAsStream(logicsheetName);
>
> It returns null, even if the logicsheetName (whose value is
'xsp-java.xsl')
> correspond to a file present in the jar file, in another branch.
>
> I tried to put a complete URL instead of just the name, putting a real
file
> to the end of it, but it didn't work.
>
> How come that getResourceAsStream, which should be looking at the
hierarchy
> does not work, and how can I fix that.
>
> Additionnaly, does anyone know how to hook a servlet to an extension on
> iPlanet ? I tried their example, but it does not seems to work...
>
> THANKS very much for helping
>
> --
> Paul Terray - terray@4dconcept.fr
> tel : 01 34 58 70 76
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message