cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Spiekermann <Markus.Spiekerm...@web.de>
Subject Re: more include
Date Wed, 02 Aug 2000 20:56:07 GMT
Hi Jeremy,

I get same error using your fp-taglib sample in a different folder than the
/samples/fp.I can look at the pages and the encoding but the ADD und EDIT buttons
won´t work.

Markus

Jeremy Quinn wrote:

> Hi,
>
> I am still having problems, this time with the util:include-file TagLib.
>
> I get this error
>
> Cocoon 1.8-dev
>
> Error found handling the request.
>
> java.lang.NullPointerException
>         at org.apache.cocoon.Utils.getBasename(Compiled Code)
>         at org.apache.cocoon.processor.xsp.XSPUtil.relativeFilename(XSPUtil.java)
>         at org.apache.cocoon.processor.xsp.XSPUtil.relativeFilename(XSPUtil.java)
>         at _SharkBait._work._xml._blah.populateDocument(_blah.java)
>         at org.apache.cocoon.processor.xsp.XSPPage.getDocument(XSPPage.java)
>         at org.apache.cocoon.processor.xsp.XSPProcessor.process(Compiled Code)
>         at org.apache.cocoon.Engine.handle(Compiled Code)
>         at org.apache.cocoon.Cocoon.service(Compiled Code)
>         at javax.servlet.http.HttpServlet.service(Compiled Code)
>         at org.apache.tomcat.core.ServletWrapper.handleRequest(Compiled Code)
>         at org.apache.tomcat.core.ContextManager.service(Compiled Code)
>         at
> org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(Compiled
> Code)
>         at org.apache.tomcat.service.TcpConnectionThread.run(Compiled Code)
>         at java.lang.Thread.run(Compiled Code)
>
> with this xml:
>
> <?xml version="1.0"?>
> <?cocoon-process type="xsp"?>
> <?cocoon-process type="xslt"?>
> <?xml-stylesheet href="../stylesheets/static.xsl" type="text/xsl"?>
> <!DOCTYPE page [
>         <!ENTITY % charEntity SYSTEM "../stylesheets/characters.ent">
>         %charEntity;
> ]>
> <xsp:page
>   language="java"
>   xmlns:xsp="http://www.apache.org/1999/XSP/Core"
>   xmlns:util="http://www.apache.org/1999/XSP/Util"
> >
>
>         <page>
>                 [snip]
>                 <title>blah</title>
>                 <body>
>                         <util:include-file name="../siteCopy/blah.xml"/>
>                 </body>
>         </page>
> </xsp:page>
>
> Might I have something wrong with my installation?
>
> thanks for any help
>
> Jeremy
> --
>    ___________________________________________________________________
>
>    Jeremy Quinn                                           Karma Divers
>                                                        webSpace Design
>                                             HyperMedia Research Centre
>
>    <mailto:sharkbait@mac.com>                    <http://www.media.demon.co.uk>
>     <phone:+44.[0].20.7737.6831>        <pager:jermq@sms.genie.co.uk>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message