cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joel Bethea" <jbet...@trisect.com>
Subject RE: cocoon2 installation issues
Date Wed, 16 Aug 2000 17:10:52 GMT
i followed your example and got a fresh version from CVS, rebuilt it, and
put everything in the right places.  im using your classpath ordering.  Both
the rebuilt versions of cocoon.jar and cocoon.war were larger than the
originals.  however, i get the same problem (NullPointerException in
SiteMapHandler).  apparently there is a setting somewhere that isn't
correct?

im trying to install it on WinNT4/Sun JDK1.2.2/Tomcat 3.1

> -----Original Message-----
> From: OD [mailto:od@feersumendjinns.com]
> Sent: Wednesday, August 16, 2000 12:25 PM
> To: cocoon-users@xml.apache.org
> Subject: Re: cocoon2 installation issues
>
>
> Just updated from the CVS, C2 is working fine for me. Nice
> new status page.
> The output in Netscape Navigator is odd but fine in Internet Explorer.
>
> WIN98SE, Sun jdk1.3, Tomcat 3.1, Cocoon2 (CVS 16/08/2k 17:23 GMT)
> Standard build, copied .war to to tomcat's webapps directory.
>
> CLASSPATH:
>
> set CLASSPATH=.
> set CLASSPATH=%TOMCAT_HOME%\classes
> rem Cocoon2
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\cocoon.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\xerces_1_1_2.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\xalan_1_0_1.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\fop_0_13_0.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\svgv_0_8.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\jstyle.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\js.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\AvalonAware.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\bsf.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\jakarta-regexp-1.1.jar
> rem Tomcat
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\webserver.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\jasper.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\xml.jar
> set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\servlet.jar
> set CLASSPATH=%CLASSPATH%;%JAVA_HOME%\lib\tools.jar
>
>
> Corey
>
>
> ----- Original Message -----
> From: Stefano Mazzocchi <stefano@apache.org>
> To: <cocoon-users@xml.apache.org>
> Sent: Tuesday, August 15, 2000 7:02 PM
> Subject: Re: cocoon2 installation issues
>
>
> > Joel Bethea wrote:
> > >
> > > Hi,
> > >
> > > In trying to get Cocoon2 up and running, I encounter the
> following error
> > > when i try to access the welcome page:
> > >
> > > Cocoon 2.0: Exception
> > > Class: java.lang.NullPointerException
> > > Message: null
> > > java.lang.NullPointerException
> > >         at
> > >
> org.apache.cocoon.sitemap.SitemapHandler.process(SitemapHandle
> r.java:145)
> > >         at
> org.apache.cocoon.sitemap.SitemapManager.invoke(SitemapManager
> .java:84)
> > >         at org.apache.cocoon.Cocoon.process(Cocoon.java:178)
> > >         at
> org.apache.cocoon.servlet.CocoonServlet.service(CocoonServlet.
> java:142)
> > >         at
> javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
> > >         at
> > >
> org.apache.tomcat.core.ServletWrapper.handleRequest(ServletWra
> pper.java:503)
> > >         at
> org.apache.tomcat.core.ContextManager.service(ContextManager.java:559)
> > >         at
> > >
> org.apache.tomcat.service.http.HttpConnectionHandler.processCo
> nnection(HttpC
> > > onnectionHandler.java:160)
> > >         at
> > >
> org.apache.tomcat.service.TcpConnectionThread.run(SimpleTcpEnd
> point.java:338
> > > )
> > >         at java.lang.Thread.run(Unknown Source)
> > >
> > > I've looked for possible conflicts in the included .jar files, and
> concluded
> > > that this problem is caused by something else.  Right
> now, (correct me
> if I
> > > am wrong, please), i think the cause could be that the URL in the
> following
> > > line from the sitemap.xmap file is not valid:
> > >
> > > <map:sitemap xmlns:map="http://apache.org/cocoon/sitemap/1.0">
> > >
> > > I have also tried the
http://xml.apache.org/cocoon/sitemap/1.0 but it
> > doesn't work either.  Has anyone else had this problem and fixed it, or
does
> > anyone know for certain that the URL is correct?
> > thanks...
>
> I'm traking down the problem right now and, no, it's not a classpath
> issue but something wrong in the code that Giacomo updated before
> leaving for vacation (Giacomo, try doing a clean rebuild and tell us if
> your stuff works on your machine because I'm having the same problem
> here)
>
> --
> Stefano Mazzocchi      One must still have chaos in oneself to be
>                           able to give birth to a dancing star.
> <stefano@apache.org>                             Friedrich Nietzsche
> --------------------------------------------------------------------
>  Missed us in Orlando? Make it up with ApacheCON Europe in London!
> ------------------------- http://ApacheCon.Com ---------------------
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org



Mime
View raw message