cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew Smith" <msm...@windebt.com>
Subject a little hack and it worked!
Date Mon, 14 Aug 2000 19:00:39 GMT
    After a lot of bitching and moaning, I finaly got cocoon to run, but
I've got some reservations about my solution.  First let me say that I'm
pretty inexperienced with java.
    I started trying to setup cocoon on a virtual server I use, iserver.
The server runs FreeBSD, Apache1.3.12 w/ Bsafe-SSL1.38, java_X1.18, and
jserv1.1.  For a long time I couldn't get cocoon to recognize the location
of its properties file.  After some more testing I realized that none of the
servlets on my virtual server would accept initargs.  I contacted the
virtual server support.  Apparently this was a common problem for all their
clients.  Somehow they'd never noticed it before (doubtful).  I was assured
that the problem had been passed to some competant technicians and was being
worked on.  A week and half later the problem still exists.
    This morning I added a line to the cocoon.java source right after the
line that captures the properties file location from the initarg.  It just
set the variable that the initarg is supposed to set, but doesn't.  I
recompiled cocoon with the build script, uploaded the new cocoon.jar,
restarted my server, and tried to load up example.xml that came with cocoon.
Success!  It works, and all the little cocoon samples load.
    BUT here's what makes me nervous - the original cocoon.jar was 218K.  My
recompiled cocoon.jar is 159K.  So, do I have reason to be concerned?

Thankyou,
Matt

Mime
View raw message