cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Scheuner" <scheu...@cos-data.de>
Subject RE: <util:include> still not working
Date Fri, 02 Jun 2000 09:19:56 GMT
Hi!

I have still a problem with <util:include>. A util-include-tag
(<util:include-file name="foo.xml"/> ), that worked in 1.7.2 now gives me
the following NPE (with 1.7.4):

                                                     Error found handling
the request.

      java.lang.NullPointerException
              at org.apache.cocoon.Utils.getBasename(Utils.java, Compiled
Code)
              at
org.apache.cocoon.processor.xsp.XSPUtil.relativeFilename(XSPUtil.java,
Compiled Code)
              at
org.apache.cocoon.processor.xsp.XSPUtil.relativeFilename(XSPUtil.java,
Compiled Code)
              at
_usr._local._tomcat._webapps._test._vereine.populateDocument(_vereine.java:8
2)
              at
org.apache.cocoon.processor.xsp.XSPPage.getDocument(XSPPage.java, Compiled
Code)
              at
org.apache.cocoon.processor.xsp.XSPProcessor.process(XSPProcessor.java,
Compiled Code)
              at org.apache.cocoon.Engine.handle(Engine.java, Compiled Code)
              at org.apache.cocoon.Cocoon.service(Cocoon.java, Compiled
Code)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java,
Compiled Code)
              at
org.apache.tomcat.core.ServletWrapper.handleRequest(ServletWrapper.java,
Compiled Code)
              at
org.apache.tomcat.core.ContextManager.service(ContextManager.java, Compiled
Code)
              at
org.apache.tomcat.service.connector.Ajp12ConnectionHandler.processConnection
(Ajp12ConnectionHandler.java, Compiled Code)
              at
org.apache.tomcat.service.TcpConnectionThread.run(SimpleTcpEndpoint.java,
Compiled Code)
              at java.lang.Thread.run(Thread.java, Compiled Code)


Do i miss here something?

Michael

>
> On Thu, 11 May 2000, Ulrich Mayring wrote:
> > <util:include-file name="foo.xml"/> generates erroneous source code,
> > there is a closing bracket missing and thus it doesn't compile.
>
> Oops! Fixed.
>
> > <util:include-uri href="foo.xml"/> just generates {foo.xml}, but doesn't
> > include anything.
>
> I added the exception message to the generated debug info. This should
> help you locate the problem...
>


Mime
View raw message