cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ricardo Rocha <rica...@apache.org>
Subject Re: A version Problem
Date Tue, 06 Jun 2000 10:01:59 GMT
Monica wrote:
> 
> >  I'm using successfully Xerces 1.0.4 with cocoon 1.7.4
> 
> I try to use them both with Xalan 1.0.1, and when I execute the xml file with
> Cocoon, I get the following:
> 
> "Cocoon 1.7.4
> 
>                              Publishing Engine could not be initialized.
> 
>      java.lang.NullPointerException
>              at org.apache.cocoon.Tokenizer.(Tokenizer.java:83)
>              at org.apache.cocoon.Tokenizer.(Tokenizer.java:120)
>              at
> org.apache.cocoon.processor.xsp.XSPProcessor.init(XSPProcessor.java:148)
>              at org.apache.cocoon.framework.Manager.create(Manager.java:101)
>              at org.apache.cocoon.framework.Router.init(Router.java:80)
>              at org.apache.cocoon.framework.Manager.create(Manager.java:101)
>              at org.apache.cocoon.Engine.(Engine.java:165)
>              at org.apache.cocoon.Engine.getInstance(Engine.java:202)
>              at org.apache.cocoon.Cocoon.init(Cocoon.java:141)  "..
> 
> Anyone have idea of what´s happening ?

Please verify that your "cocoon.properties" file has a "languages"
subsection
for XSP:

  # supported languages
  processor.xsp.languages = java

In absence of this directive, Cocoon will throw the exception shown
above.

In my opinion, this is not related with the Xerces version...

Mime
View raw message