cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Valdas Varnagiris" <val...@nomagiclt.com>
Subject Re: XML DTD validating
Date Fri, 30 Jun 2000 12:49:47 GMT
Thanks a lot,
i did as you said, but the problem remains...

Does anybody know how to force Cocoon to validate XML in accordance with DTD
????

----- Original Message -----
From: "Paul Russell" <paul@luminas.co.uk>
To: <cocoon-users@xml.apache.org>
Sent: Friday, June 30, 2000 1:38 PM
Subject: Re: XML DTD validating


> Valdas,
>
> On Fri, Jun 30, 2000 at 01:17:50PM +0200, Valdas Varnagiris wrote:
> > And now Xerces parser always throws exception when parsing any xml file:
> > java.lang.RuntimeException: org.xml.sax.SAXParseException: Attribute
"version" must be declared for element type "xsl:stylesheet".
> > Maybe anyone know where is the problem and how can i turn the validation
on?
> > Thanks ...
>
> The 'version' attribute of the <xsl:stylesheet> is required,
> your stylesheets should look (broadly) like:
>
> <?xml version="1.0"?>
> <xsl:stylesheet version="1.0"
> xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
> <!-- xsl:templates etc here -->
> </xsl:stylesheet>
>
> Hope that helps,
>
> --
> Paul Russell                               <paul@luminas.co.uk>
> Technical Director,                   http://www.luminas.co.uk
> Luminas Ltd.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message