cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cliff Harker" <Cliff_Har...@figroup.co.uk>
Subject Using Cocoon with Inprise Application Server 4.02 on Win2K
Date Wed, 07 Jun 2000 15:42:51 GMT
I've been playing with the latest Cocoon distribution and managed to get it
working with IAP and thought other people might be interested in how I got it
working.

I'm using

   IAS 4.02 available as a free download from the Inprise site.  This is a newer
   version than the one with JBuilder 3.5.
   Windows 2000 Server

I have Cocoon expanded into

     c:\cocoon\cocoon-1.7.4

I have IAS installed in

     c:\IAS4

To install....

Copy c:\cocoon-1.7.4\bin\cocoon.jar to c:\ias4\servlets
Copy c:\cocoon-1.7.4\lib\*.jar to c:\ias4\lib
Copy c:\cocoon-1.7.4\conf\cocoon.properties to c:\ias4\properties

Run the IAS admin screen with http://server:9090

Login (admin, admin)
Select HTTP Web Engine and click the Manage button
In Servlet Aliases add *.xml invokes cocoon
Select Servlets in the toolbar
Select Add (servlet) from the left panel

Enter
     Servlet Name - cocoon
     Servlet Class - org.apache.cocoon.Cocoon
     Bean Servlet - no

Click Add

On the Configuration tab
     Description - whatever you like
     Servlet Class - as above
     Load at Startup - yes

On the Properties tab
     add new variable (name = properties, Value =
./properties/cocoon.properties)
     Click Save

Now click Load to see if it loads...

Test by entering

     http://server:8080/Cocoon.xml

Hope you find this useful

Cliff




Mime
View raw message