cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rafael Oropeza <rorop...@eud.com>
Subject Re: wap example isn't working in wap emulators
Date Fri, 19 May 2000 18:07:56 GMT
The exact  USER_AGENT in my case is (this fragment was taken from acces_log
Apache Web Server Access log file)

10.3.0.6 - - [10/May/2000:12:44:10 -0400] "GET
/samples/wap/example-portfolio.xml HTTP/1.1" 200 1579 "-"
"Nokia-WAP-Toolkit/1.3beta"

So, I wrote this in my cocoon.properties file in many combinations (of
course, not at the same time, just one by one and restarting the server
every time)

1) browser.8 = wap=Nokia-WAP-Toolkit
2) browser.8 = wap=Nokia
3) browser.8 = wap=Nokia-WAP-Toolkit/1.3beta

In my case, my server always return to my Nokia Wap Browser (BTW, this is
another box, not my main apache + cocoon main server) the MIME type
"text/html", firing an error. I revisited mime.types, checked xsp file
(<?xml-stylesheet href="portfolio-wml.xsl" type="text/xsl" media="wap"?>),
also  checked the xsl file (<xsl:processing-instruction
name="cocoon-format">type="text/vnd.wap.wml"</xsl:processing-instruction>)
tryng to write the exact mime type required by Nokia Wap Browser whitout
success. I checked the Nokia toolkit configuration and everything is okay.

What's wrong? My last chance is install jakarta instead jserv and try.

Sebastien Koechlin I-VISION wrote:

> Rafael Oropeza wrote:
> >
> > I made the same question but nobody said nothing. I suppose the answer
> > is so obvious that noone are worrying about that. BTW, I still think
> > this is a MIME type problem not correctly setting by Cocoon. If write
> > a static .wml file into my Apache web server and contact it with Nokia
> > Wap toolkit everything runs fine.
> >
> > Please, if somebody can help, I appreciate it so much.
> >
> > ling.shi@bi.no wrote:
> >
> > > Hei,
> > > I have Tomcat3.1b running with cocoon on win2000. Most of the xml
> > > pages work
> > > fine in IE or NS, including example-portfolio.xml . But it doesn't
> > > work when I
> > > use a wap emulator to read it:
> > > http://myserversIpAddress:8080/xmlsample/wap/example-portfolio.xml
> > >
> > > If I use winwap browser,  the error message is: The content
> > > retreived is of HTML
> > > type. This can not be shown by the WinWap browser..."
>
> Try with a HTML browser and ask for
> http:/...../example-portfolio.xml?user-Agent=Nokia
>
> If there are errors, they will be displayed in a HTML page.
>
> If there are no, try to look at the result (you may have to save
> it to disk before), and check it.
>
> > > The other browsers I tried is Nokia wap toolkit and other two on the
> > > internet:
> > > http://www.gelon.net , http://www.wapjag.com
> > >
> > > Anyone has some ideas to work through this? Thanks ahead.
>
> Do you know what are the exacts USER_AGENT strings ?
> Does they match any browser in cocoon.properties ?
>
> --
> Sebastien Koechlin
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org

--
Rafael Alberto Oropeza Baudet

(16) Before you can be creative, you must be courageous. Creativity is the
destination, but courage is the journey.
Joey Reiman


Mime
View raw message