cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve K <sk...@yahoo.com>
Subject Cocoon and Jetspeed not getting along
Date Fri, 19 May 2000 22:52:06 GMT
Hey all --

I have both Cocoon 1.7.3 and Jetspeed 1.1 (which uses Cocoon) installed on the
same server (RedHat 6.2 / Apache 1.3.12 / JServ 1.1).  I have Cocoon installed
on the JServ that Apache is set to automatically start up and this works fine. 
I set up a whole other instance of JServ that I start manually for Jetspeed and
this works fine as well.

When I manually start up the JServ for Jetspeed, the problems with Cocoon
begin.
When I hit a .xml document, sometimes I get just the source of the XML document
or sometimes I get an error from Cocoon saying it can't parse the document (it
looks like it is trying to parse the document twice).  If I send a HUP to
apache it seems to fix the problems -- but as soon as I request a page from
Jetspeed again it starts acting up.

I thought the problem might be some overlapping config files between the main
install of Cocoon and the Cocoon that Jetspeed uses but everything there seems
ok.  I did add the following to my httpd.conf file to have Cocoon ignore .xml
files in my /content directory which Jetspeed uses:

----

Action cocoon /cocoon/org.apache.cocoon.Cocoon
AddHandler cocoon xml

<Location /content>
        RemoveHandler xml
</Location>

----

And this appears to work as expected.  Anyone have any ideas?

Thanks!
-steve



__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

Mime
View raw message