cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robin Green" <gree...@hotmail.com>
Subject Re: Solaris againe ......
Date Fri, 05 May 2000 16:44:27 GMT
It's possible your cocoon.jar may be corrupt. Have you tried downloading 
cocoon again and reinstalling it?

"Taras Shumeyko" <noise@humgat.kiev.ua> wrote:
>I run Cocoon without JIT compiler but ... but not have error line
>number.
>We still have this error.
>-----------------------
>java.lang.ArrayIndexOutOfBoundsException: -47330168
>at org.apache.cocoon.processor.xsp.XSPPage.getDocument(Compiled Code)
>at org.apache.cocoon.processor.xsp.XSPProcessor.process(Compiled Code)
>at org.apache.cocoon.Engine.handle(Compiled Code)
>at org.apache.cocoon.Cocoon.service(Compiled Code)
>at javax.servlet.http.HttpServlet.service(Compiled Code)
>at org.apache.jserv.JServConnection.processRequest(Compiled Code)
>at org.apache.jserv.JServConnection.run(Compiled Code)
>at java.lang.Thread.run(Compiled Code)
>------------------------
>
>Here is how it happens:
>
>Let's suppose that after modification of .xsp source code we have "null
>pointer exception" in some line.
>This is really my mistake, and I correct this line. Then I'm requesting
>this page and have right result without errors. After 3th or 4th
>requests we have "java.lang.ArrayIndexOutOfBoundsException: -47330168"
>error.
>We tried turn on "log.level = debug" in cocoon.properties,
>"wrapper.bin.parameters="-Xms16M -Djava.compiler=NONE -Xt" " in
>jserv.properties,
>but have not any error line number.
>
>
>Cocoon very GOOD stuff, but with this bug it's not usable for us.
>We run at : Solaris 7, Java 1.2.2_005, Jserv 1.1, Cocoon1.7.3-dev,Apache
>3.12
>
>P.S. on NT with same software configuration we don't have any problems.
>please help with this trouble.
>
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
>For additional commands, e-mail: cocoon-users-help@xml.apache.org
>

________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com


Mime
View raw message