cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Yancy <kya...@geobot.com>
Subject RE: Cocoon 1.7 with WebLogic 5.1.0. (was Cocoon 1.6.1 with WebLogic 5.1.0.)
Date Fri, 28 Apr 2000 04:15:49 GMT
Hiya

Wellllll...... come to find out it's not *completely* working yet. The XSP
examples don't work but the problem looks fixable for someone who knows a little
more about XSP. I just get a bunch of "class not found" messages when it tries
to compile the page (see below). But, everything else works, including invoking
Cocoon from a servlet. This is on Winduhs NT by the way.

Let me start with a disclaimer... I still consider myself a newbie at all this
so I won't even try to explain the "why" part of how this worked and I apologize
for the narrative.

For simple processing, setup was pretty easy. But I had to be able to invoke
Cocoon directly as well from a servlet for an application I'm doing. I spent
most of my time just trying to mix and match versions of the JARs to get this to
work. I could *not* get Cocoon 1.7.1 or 1.7.2 to work!? Just the right
combination of JARs is what got me going. Rather than ramble, here's excerpts
from my startweblogic.cmd file, weblogic.properties, and that XSP error I still
get.

Look at the JAR names in weblogic.cmd to determine the versions I ended up
using. Maybe this will be helpful to someone. Good luck. Let me know if anyone
knows what the XSP problem may be.

================================
+The XSP error I still get on the /xsp examples
================================
java.lang.Exception: XSP Java Compiler: Compilation failed for _page.java
      6: Package org.w3c.dom not found in import.
          import org.w3c.dom.*;
                 ^
      7: Package org.xml.sax not found in import.
          import org.xml.sax.*;

 . ........... and so on for all the imports.

===============================================
+ Excerpts from weblogic.properties. I registered .xml file type.
+ Set case sensitivity for NT
===============================================
weblogic.httpd.register.*.xml=org.apache.cocoon.Cocoon
weblogic.httpd.initArgs.*.xml=properties=D:/conf/cocoon.properties

weblogic.httpd.servlet.extensionCaseSensitive=true

==============================================================
-- CLASSPATH from startweblogic.cmd
==============================================================
rem Could not get anything later than v.1.7 to work
SET COCOON=D:\classes\cocoon-1_7.jar
SET XERCES=D:\Apache\cocoon-1.7.2\lib\xerces_1_0_3.jar
SET COCOONSTYLE=D:\Apache\cocoon-1.7.2\lib\stylebook-1.0-b2.jar
SET COCOONFOP=D:\Apache\cocoon-1.7.2\lib\fop_0_12_1.jar
SET XALAN=D:\Apache\cocoon-1.7.2\lib\xalan_1_0_0.jar
SET COCOONJARS=%COCOON%;%COCOONSTYLE%;%COCOONFOP%;%XERCES%;%XALAN%

SET TURBINE=D:\classes\turbine-2.0.jar
SET CASTOR=D:\classes\castor-0.7.4.jar
SET VILLAGE=D:\classes\village-1.2.jar
SET MYSQL=D:\classes\mysql_uncomp.jar
SET ECS=D:\classes\ecs-1.3.2.jar
SET JAF=D:\jaf-1.0.1\activation.jar
SET JAXP=E:\geobot\uv\3rdparty\jaxp\jaxp.jar
SET LOG4J=E:\geobot\uv\3rdparty\log4j\log4j.jar
SET JAVAMAIL=D:\javamail-1.1.2\mail.jar

REM ************ Set the CLASSPATH ************
set PRE_CLASSPATH=%COCOONJARS%;E:\weblogic\eval\cloudscape\lib\cloudscape.jar
set
POST_CLASSPATH=%JAXP%;%JAVAMAIL%;%VILLAGE%;%MYSQL%;%TURBINE%;%ECS%;%CASTOR%;%JAF%;

==============================================================
+ I use Xerces with JAXP for parsing
==============================================================
REM ************ Set the parser to Xerces with JAXP ************
set
JAVA_OPTIONS=-Djavax.xml.parsers.DocumentBuilderFactory=org.apache.xerces.jaxp.DocumentBuilderFactoryImpl



good luck!

Simon wrote:

> Me too!  WebLogic is such a bitch to figure out the classpath's for it would
> be great to have a heads up on how to do this for 5.1.0.  Or maybe it was
> obvious in the first place and I'm stupid - but the volume of email on this
> subject seems to indicate otherwise!
>
> -----Original Message-----
> From: Russell Castagnaro [mailto:russell@synctank.com]
> Sent: Wednesday, April 26, 2000 10:01 AM
> To: cocoon-users@xml.apache.org
> Subject: Re: Cocoon 1.6.1 with WebLogic 5.1.0.
>
> OK Kevin..  don't keep us in suspense.
>
> can you post the settings that you used?  Were you on NT, Solaris, Linux?
> Thanks
>
> Kevin Yancy wrote:
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org

--
Kevin Yancy
--
kyancy@geobot.com
http://www.geobot.com



Mime
View raw message