cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Werner Guttmann <Werner.Guttm...@msdw.com>
Subject Re: XSP Taglib frustrations
Date Thu, 06 Apr 2000 08:44:13 GMT
Roger,

I had the same problem the other day, and I kind of solved this issue by
dropping the file:// protocol indicator from the relevant line in
cocoon.properties. In other words, switching from ...

processor.xsp.logicsheet.example.java =
file:///home/httpd/html/example.xsl.

to

processor.xsp.logicsheet.example.java =
/home/httpd/html/example.xsl.

worked for me. Maybe somebody else could comment on why things do not work as
intended.

Regards
Werner Guttmann

Roger Vaughn wrote:

> I'm having trouble with XSP taglibs.
>
> I first couldn't figure out how to associate an XSP sheet to a source page -
> I *finally* found the section in cocoon.properties for it.  This ought to
> get doc'ed somewhere in the online XSP intros.
>
> After finding the section, I added this line to my cocoon.properties:
>
>   processor.xsp.logicsheet.example.java =
> file:///home/httpd/html/example.xsl.
>
> Now, when I try to pull up my XML example, I get an exception from Cocoon -
> a NullPointerException at XSPProcessor.java:359 (in the process method).  (I
> also tried putting "localhost" in the hostname slot.)
>
> Any hints why this is happening?  I would guess that the processor isn't
> finding my file, but I would hope there would be an explicit check for that
> condition.
>
> Thanks for any help.
>
> rog
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org

Mime
View raw message