cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edas Pazera" <e...@usa.net>
Subject XSP Problem
Date Thu, 06 Apr 2000 02:10:26 GMT
I have an interesting problem with XSP processor.  If I enable (uncomment) XSP processor association
in Cocoon.properties file, then Cocoon essentially stops working for everything else.  It
gives me an error about failure to initialize the publishing Engine.  When I disable it, everything
works just fine.

For the reference, my setup is:

Win98
Apache 1.12
JServ 1.1

wrapper.classpath for cocoon.jar and other JARs are set
I do not use CLASSPATH, but instead place all JARs in EXT directory of my Java installation
(proved to work for everything so far)
repository folder set by an absolute path (tried relative as well)

Any ideas?

Thanks a bunch!

--Edas

P.S.  Full error message below--


Publishing Engine could not be initialized.
java.lang.NullPointerException
	at org.apache.cocoon.Tokenizer.(Tokenizer.java:83)
	at org.apache.cocoon.processor.xsp.XSPProcessor.init(XSPProcessor.java, Compiled Code)
	at org.apache.cocoon.framework.Manager.create(Manager.java:101)
	at org.apache.cocoon.framework.Router.init(Router.java, Compiled Code)
	at org.apache.cocoon.framework.Manager.create(Manager.java:101)
	at org.apache.cocoon.Engine.(Engine.java:161)
	at org.apache.cocoon.Engine.getInstance(Engine.java:196)
	at org.apache.cocoon.Cocoon.init(Cocoon.java:119)
	at org.apache.jserv.JServServletManager.load_init(JServServletManager.java:569)
	at org.apache.jserv.JServServletManager.loadServlet(JServServletManager.java:488)
	at org.apache.jserv.JServConnection.processRequest(JServConnection.java:266)
	at org.apache.jserv.JServConnection.run(JServConnection.java:188)
	at java.lang.Thread.run(Thread.java:479)



Mime
View raw message