cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Rolston" <rols...@healthnetint.com>
Subject SQLProcessor problems
Date Sat, 04 Mar 2000 05:11:24 GMT
Hello,

I'm having problems with the SQLProcessor function. I'm running Apache
1.3.11 with Jserv 1.1-2 and Cocoon 1.6 on Red Hat Linux 2.2.12-20 and I've
tried to create a simple test file and it appears that the tags for creating
the connection (as well as the <query> tag) don't seem to be recognized. For
example:

Test file:

<?xml version="1.0" encoding="UTF-8"?>
<?cocoon-process type="sql"?>

<?xml-stylesheet href="sql_test.xsl" type="text/xsl"?>
<?cocoon-process type="xslt"?>
<sql_test_page>

<connectiondefs>
   <connection name="foo_con">
     <driver>oracle.jdbc.driver.OracleDriver</driver>
     <dburl>jdbc:oracle:thin:@XX.XX.XX.XX:1521:hni01d</dburl>
     <username>foobar</username>
     <password>foobar</password>
   </connection>
</connectiondefs>

<query connection="foo_con">
select NAME from EMP
</query>

</sql_test_page>

and what I get in the browser window is the following text line:

oracle.jdbc.driver.OracleDriver jdbc:oracle:thin:@XX.XX.XX.XX:1521:hni01d
foobar foobar select NAME from EMP

What this tells me (and I could be wrong) is that the SQLProcessor is not
processing the tags and just spitting out the text in the tags and not
interpreting them. I've looked at the SQLProcessor code (which looks to be
right) but I haven't re-compiled it and put it into the jar (though I'm not
sure of the efficacy of this). Has anyone any ideas as too where to look?
I'm probably missing something obvious but... perhaps a second pair of eyes
will see clearer.

Bill


Mime
View raw message