cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Dzmura <...@digital-mission.com>
Subject Cocoon-1.7 blowing up on xdocs/ tree
Date Thu, 09 Mar 2000 17:26:43 GMT
Dear Folks:

I have just upgraded a development box from Cocoon-1.5 to Cocoon-1.7.  I first found that
stricter  parsing required me to make some fixes to some .xsl files, then our old stuff
worked (except for the PDF's...)

Then I copied the "xdocs" tree under the htdocs/ directory of the main servlet zone and
tried to look at "http://localhost/xdocs"  This is what I get when Cocoon-1.7 tries to process
the file "index.xml" (or any other .xml file) in the "xdocs" directory.

Any ideas??  I don't think there are any configuration problems, and I am using the standard
out-of-the-box .jar's for all the processors, etc...

Regards,
Mark Dzmura

    Cocoon 1 shows that Open-source software can define the state of the art...
    Cocoon 2 will rule the world!!

---------------


Cocoon 1.7

                                                            Error found handling the request.

                       java.lang.NullPointerException:
                               at
org.apache.xml.serialize.BaseMarkupSerializer.printDoctypeURL(BaseMarkupSerializer.java:1261)
                               at
org.apache.xml.serialize.BaseMarkupSerializer.unparsedEntityDecl(BaseMarkupSerializer.java:638)
                               at
org.apache.xml.serialize.BaseMarkupSerializer.serializeNode(BaseMarkupSerializer.java:773)
                               at org.apache.xml.serialize.BaseMarkupSerializer.serialize(BaseMarkupSerializer.java:385)

                               at org.apache.cocoon.formatter.HTMLFormatter.format(HTMLFormatter.java:80)
                               at org.apache.cocoon.Engine.handle(Engine.java:296)
                               at org.apache.cocoon.Cocoon.service(Cocoon.java:145)
                               at javax.servlet.http.HttpServlet.service(HttpServlet.java:588)
                               at org.apache.jserv.JServConnection.processRequest(JServConnection.java:314)
                               at org.apache.jserv.JServConnection.run(JServConnection.java:188)
                               at java.lang.Thread.run(Thread.java:479)

----------------------------

On another point, I see that somebody has decided to go away from the clever Jar file usage
back to boring old tarballs... Personally, I prefer the GNU convention of actually creating
the top level, versioned directory as opposed to the heinous ZIP-file convention of just
dumping the stuff in the current directory.  In other words, the root of the tarball should
be



Mime
View raw message