cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastian Hauer <ha...@uni-freiburg.de>
Subject Re: Installation problems
Date Tue, 29 Feb 2000 11:27:27 GMT

Hi Peter,

I get exactly the same error under linux. I'm running sun's JDK 1.2.2 and
when I use the JSDK 2.2 that it shipped with Cocoon called servlet_2_2.jar
I will always get that error.

So I changed to the old JSDK 2.0 from sun at:
http://www.javasoft.com/products/servlet/download.html

I changed the classpath in my jserv.properties file from 

wrapper.classpath=/usr/local/servlets/cocoon/lib/servlet_2_2.jar

to

wrapper.classpath=/usr/lib/jsdk/lib/jsdk.jar

and now it is working.

I still don't know why I can't use the JSDK 2.2 even though it comes with
cocoon 1.7. Does anyone know?

bye,
	Sebastian

On Tue, 29 Feb 2000, MORÁVEK Peter wrote:

> The Apache is running well, the JServ is running well, but when I want to
> run the /Cocoon.xml
> there is a log entry :
> [29/02/2000 11:32:30:707 GMT+01:00] java.lang.AbstractMethodError:
> org/apache/jserv/JServContext.getContext
> 	at
> org.apache.jserv.JServServletManager.load_init(JServServletManager.java:579)
> 	at
> org.apache.jserv.JServServletManager.loadServlet(JServServletManager.java:48
> 8)
> 	at
> org.apache.jserv.JServConnection.processRequest(JServConnection.java:266)
> 	at org.apache.jserv.JServConnection.run(JServConnection.java:188)
> 	at java.lang.Thread.run(Thread.java:479)


Mime
View raw message