cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastian Hauer <ha...@uni-freiburg.de>
Subject config question (Cocoon 1.7)
Date Mon, 28 Feb 2000 23:56:46 GMT

Hi,

I just more or less successfully setup cocoon.
It was a little tricky and I had to change some stuff I had not expected
to.

The funny thing is that cocoon is running and I have no problems to
transform my xml files into html.
But when ever I try to do a :

http://localhost/Cocoon.xml

All I get is a:
---------------------------------snip----------------------------------
                      Publishing Engine could not be initialized.

java.lang.RuntimeException: 
Error creating org.apache.cocoon.processor.ldap.LdapProcessor: 
make sure the needed classes can be found in the classpath
(javax/naming/directory/DirContext)
              at org.apache.cocoon.framework.Manager.create(Manager.java:102)
              at org.apache.cocoon.framework.Router.init(Router.java:80)
              at org.apache.cocoon.framework.Manager.create(Manager.java:89)
              at org.apache.cocoon.Engine.(Engine.java:155)
              at org.apache.cocoon.Engine.getInstance(Engine.java:190)
              at org.apache.cocoon.Cocoon.init(Cocoon.java:119)
              at org.apache.jserv.JServServletManager.load_init(
			JServServletManager.java:569)
              at org.apache.jserv.JServServletManager.loadServlet(
			JServServletManager.java:488)
              at org.apache.jserv.JServConnection.processRequest(
			JServConnection.java:266)
              at org.apache.jserv.JServConnection.run(JServConnection.java:188)
              at java.lang.Thread.run(Thread.java:475)
-------------------snap----------------------------------------------------

and I don't know why.
Well as I mentioned I had to do some changes to get cocoon actually
running.

Here are some lines out of my jserv.properties:
-------------snip-------------------------
wrapper.bin=/usr/lib/jdk1.2.2/bin/java
wrapper.classpath=/usr/local/apache/libexec/ApacheJServ.jar
wrapper.classpath=/usr/lib/jsdk/lib/jsdk.jar
#wrapper.classpath=/usr/local/servlets/cocoon/lib/servlet_2_2.jar
wrapper.classpath=/usr/local/servlets/cocoon/bin/cocoon.jar
wrapper.classpath=/usr/local/servlets/cocoon/lib/fop_0_12_1.jar
wrapper.classpath=/usr/local/servlets/cocoon/lib/xalan_0_19_4.jar
wrapper.classpath=/usr/local/servlets/cocoon/lib/xerces_1_0_1.jar
-------------snap-------------------------

I was not able to use the servlet_2_2.jar JSDK that was included with my
cocoon 1.7. I don't know why. Maybe because I'm running Sun's JDK 1.2
under Linux??? The old JSDK 2.0 was just working fine.

But to get cocoon working I also had to make some changes to my
cocoon.properties. Here are the lines I had to change:

---------------snip-----------------------------------------
processor.xsp.repository = /usr/local/apache/xsp/repository

# LDAP Processor
#processor.type.ldap = org.apache.cocoon.processor.ldap.LdapProcessor
---------------snap-----------------------------------------

I don't know why I had to comment out the processor.type.ldap line but
it worked.

It would be realy nice if someone could help me out to properly setup
cocoon.

Thanks in advance,

         	Sebastian



Mime
View raw message