cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William Kuhn <wk...@biostat.ufl.edu>
Subject cocoon install question
Date Tue, 15 Feb 2000 04:35:25 GMT
I posted some questions/problems I was having getting cocoon installed,
but never got any replies.

In the meantime I managed to figure out that one problem was that cocoon
was complaining about not enough memory.  I'm running it on rh6.1.  I
read the documentation that addressed this condition and was even more
confused.  It said the preferred method of solving this problem is to
pass command line options to the java interpreter.  I tracked down the
correct property in one of the jserv configuration files, but prior to
adding the options (-Xms and -Xmx) I figured I'd try the options on the
command line.  I'm not sure what units the memory are to be given in
(bytes, kb, or mb??) so I tried sensible options for all three with no
success.  What I mean by sensible is that the minimum initial (-Xms)
needs to be less than the max (-Xmx).  In all cases, however, I received
an error message that said that the minimum must be less than the
maximum which didn't make any sense since I had set the minimum less
than the maximum.

So, then I tried to *increase* the memory in cocoon.properties to 2x10^6
(from the default of 2x10^5) and that didn't help.  Reading the
documentation a little further it appeared that *decreasing* this
setting might help get cocoon working (albeit not optimally) so I
dropped it to 2000.  Cocoon seemed to work then.  I'm not satisfied with
this approach and would like some advice on how to set up cocoon
properly for production use.  Any help would be appreciated.

Okay, so now cocoon is running but when I request .xml documents my web
server returns the .xml file rather than passing the request to the
cocoon servlet.  I followed the instructions and added the ApJservAction
line to jserv.conf.  I saw mention on a message board that Action and
AddHandler could somehow be used to overcome this problem, but what I
read didn't give specifics.  I could use any help I can get.  The only
way I can run cocoon currently is to request (for example)
http://localhost/servlets/cocoon/somepath/somefile.xml.

I'd be very appreciative if someone could take a couple of minutes to
help me.  I think that cocoon is a powerful tool and I have several
applications for it that are on hold until I can get it working
properly.

Thanks in advance for whoever answers.

-Bill
-- 
Bill Kuhn
Coordinator of Computer Applications
Division of Biostatistics
University of Florida
Mime
View raw message