cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ross Burton" <bur...@dcs.kcl.ac.uk>
Subject Re: Installing Cocoon 1.7
Date Fri, 25 Feb 2000 19:13:44 GMT
> > xml.jar (Sun ProjectX) is required by ant. We might remove that
> > dependency in the future.

Okay, doing this is easier than I thought.  If you want to remove the
dependancy on xml.jar (aka Sun's ProjectX), do the following

* edit jakarta-ant/src/main/org/apache/tools/ant/parser.properties to
contain:
    parser=org.apache.tools.ant.ApacheParser

* delete jakarta-ant/src/main/org/apache/tools/ant/SunParser.java if you
want to remove xml.jar totally (if it remains there will be a compilation
error as xml.jar is not present)

* edit jakarta-ant/bootstrap.[bat|sh] so that the path to xerces.jar is
mentioned instead of lib/xml.jar

* run bootstrap.[bat|sh] and hope it works!

Would it be possible to commit the required changes to jakarta-ant so that
it uses Xerces instead of ProjectX?

Ross Burton


Mime
View raw message