cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From john.d.g...@bellatlantic.com
Subject RE: problem with following-sibling::?
Date Tue, 11 Jan 2000 13:44:59 GMT



Hi Toby,

Thanks for the suggestion. The default install of Coccon 1.5 uses the XSL:P
processor from http://xslp.kvisco.com/
instead of Xalan. As near as I can figure out, it doesn't handle Axes, as I got
the following to work:

          <xsl:apply-templates select="../node()[position()=1]" />

but the equivalent statement, without the abbreviated syntax, causes the process
 to fail at that line:

          <xsl:apply-templates select="../child::node()[position()=1]" />

My syntax is correct, right??

I tried downloading Xalan and running my xml & xsl through it, but it complains
about things that XSL:P seems to take in it's stride. It keeps giving me
messages like "problem at line x column y - null".  I will have to figure out
what I am doing wrong and then plug Xalan in to Cocoon.

Thanks & regards,
John Gray






"Toby Ferguson" <toby.ferguson@eloan.com> on 01/10/2000 05:41:22 PM

To:   John D. Gray@NYNEX
cc:
Subject:  RE: problem with following-sibling::?



John,

I was playing around this weekend with axes, and got them to work AOK -
however I was merely playing with Xalan, as opposed to Cocoon, so maybe I
was doing something differently.

Have you tried just running a simple example through Xalan and checking that
your syntax and ideas are correct, before attempting to run it all the way
through Cocoon?

Toby Ferguson
ELOAN

> -----Original Message-----
> From: john.d.gray@bellatlantic.com [mailto:john.d.gray@bellatlantic.com]
> Sent: Monday, January 10, 2000 2:02 PM
> To: cocoon-users@xml.apache.org
> Subject: problem with following-sibling::?
>
>
>
>
>
> Hi,
>
> Has anyone encountered any problems with Xpath statements like
> following-sibling::node()[1]
> when using the cocoon default xslt processor ( processor.type.xslt =
> org.apache.cocoon.processor.xslt.XSLPProcessor )?
>
> Regards,
> John Gray
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org
>







Mime
View raw message