cocoon-users-fr mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From clodeindustrie <clodeindust...@gmail.com>
Subject Re: 2 PB : l'eternel block JMS et le forms-lib.js pour les Cforms
Date Tue, 25 Jul 2006 08:23:32 GMT
clodeindustrie <clodeindustrie <at> gmail.com> writes:

> 
> bonjour,
> J'ai deux problemes qui m'empoisonnent actuellement.
> 1:)
> Le probleme du block jms qui semblent revenir souvent, j'ai trouvé des
> tonnes de solutions différentes sur le net mais aucune qui ne marche avec
> moi, je rappel les faits:
> Je veux déployer ma servlet cocoon dans jboss, quand je déploie le cocoon de
> base sans rien en plus tout va bien. Cependant quand je pack avec, un
> pipeline de ma fabrication (qui marche sous jetty), dont la page xsp fait
> appel à un jar externe qui fait lui meme appel à un datasource jboss ça ne
> marche plus. Il semble que le fait d'appeler le datasource necessite le
> block JMS. Quand je rajoute le jar openjms-0.7.6.1.jar comme il est
> conseillé sur les forums, ça ne marche pas non plus.
> Si avec ces informations vous avez une idée pour résoudre le probleme je
> suis preneur, sinon je rajouterais des précisions sur la nature des erreurs
> dans la journée.
> 
> 2:)
> Là encore c'est un probleme qui semble récurrent mais je n'en ai pas trouvé
> la solution. J'utilise des Cforms avec des controles dynamique (en fait
> l'exemple de base du wiki cocoon), le probleme c'est que ces controles
> dynamiques ne sont pas effectués car ma page ne trouve jamais le
> form-lib.jsqui pourtant se trouve à l'emplacement indiqué. j'ai essayé
> d'inclure pour
> tester un fichier.js de ma fabrication et j'obtiens là même erreur.
> Quelqu'un sait il comment faire pour que mes fichiers inclut soir trouvés ?
> 
> Voila, je suis disponible immediatement pour tout renseignement
> supplémentaire,
> j'espere ne pas poser de questions stupide, en effet je débute sur cocoon.
> merci
> 

Je m'auto répond :)
apres expérimentations hier, j'ai découvert que pour mon probleme 1
il ne s'agit pas de jms en fait il semble que c'est juste mes pages XSP qui ne
passent pas. J'ai tout repris depuis le début en faisant un test trés unitaire
avec ajout  de fonctionnalité pas à pas (du debug quoi) et quand j'ai ajouté mon
XSP qui pourtant ne fait absolument rien, ça plante. Je vais chercher dans cette
direction, mais si quelqu'un connait le probleme je veux bien l'entendre :)
merci



---------------------------------------------------------------------
Liste francophone Apache Cocoon -- http://cocoon.apache.org/fr/
Pour vous desinscrire : mailto:users-fr-unsubscribe@cocoon.apache.org
Autres commandes : mailto:users-fr-help@cocoon.apache.org


Mime
View raw message