cocoon-docs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From d...@cocoon.apache.org
Subject [Cocoon Wiki] Updated: Installing
Date Wed, 15 Dec 2004 16:52:45 GMT
   Date: 2004-12-15T08:52:45
   Editor: BertrandDelacretaz <bdelacretaz@codeconsult.ch>
   Wiki: Cocoon Wiki
   Page: Installing
   URL: http://wiki.apache.org/cocoon/Installing

   make sure people know about the install.txt "no-install" installation

Change Log:

------------------------------------------------------------------------------
@@ -1,6 +1,11 @@
-Cocoon is web application which can be deployed on number of Java Servlet Engines. [http://cocoon.apache.org/2.1/installing/index.html
Official installation guide] has lots of information on this subject.
+Cocoon is a web application which can be deployed on number of Java Servlet Engines. Here
are some complements to the [http://cocoon.apache.org/2.1/installing/index.html Official installation
guide], which has lots of information on this subject.
 
-Here are updates to this guide which did not make into official guide yet.
+= Related information =
+ * See also [:CocoonEasyInstallation]
+ * If you just want to test Cocoon or play with the samples, see the INSTALL.txt file in
the Cocoon distribution, or the [http://cocoon.apache.org/2.1/howto/howto-explore-samples.html
How to run and explore the Cocoon samples] page. 
+
+= Additional installation information =
+Here are updates to this guide which did not make into the official guide yet.
  *  '''"Could not create task or type of type: if." error''': The cause of this error is
use of a system-installed Ant instead of the one provided with Cocoon. The provided Ant defines
the <if> task. Workaround: uninstall the system Ant. If you don't want to do that, you
might try editing the tools/bin/ant script to force it to use Cocoon's Ant instead of the
system one (I haven't tried that). This error is known to occur on Linux (SuSE and Fedora)
with Cocoon 2.1.5.1 and 2.1.6. (Reported by Lars Huttar; thanks to Antonio Gallardo for the
fix.)
 
  *  '''[http://fedora.redhat.com/ Linux Fedora Core 1, 2 or 3 ]''': Comes with own versions
for {{{java, javac, jar}}} and optionally for {{{ant}}}. You need to remove the links placed
in {{{/usr/bin}}} for this files. All these files are pointing to {{{/etc/alternatives}}}
and from there point to {{{/usr/share/java/libgcj-java*-placeholder.sh}}}. Then read [:Cocoon2.1m2SetupLinuxredhat8.0]

Mime
View raw message