cocoon-docs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stev...@outerthought.org
Subject [WIKI-UPDATE] LatestRelease Main NoMoreDtmIdError XPatchTaskUsage YourCocoonBasedProject Wed Jun 4 02:00:07 2003
Date Wed, 04 Jun 2003 00:00:07 GMT
Page: http://wiki.cocoondev.org/Wiki.jsp?page=LatestRelease , version: 8 on Tue Jun  3 23:20:43
2003 by JoergHeinicke

- The latest release is __2.2 Milestone 2__. [This message|http://marc.theaimsgroup.com/?l=xml-cocoon-users&m=105161752627911&w=2]
explains what we mean by Milestone release.
?                           ^

+ The latest release is __2.1 Milestone 2__. [This message|http://marc.theaimsgroup.com/?l=xml-cocoon-users&m=105161752627911&w=2]
explains what we mean by Milestone release.
?                           ^



Page: http://wiki.cocoondev.org/Wiki.jsp?page=Main , version: 196 on Tue Jun  3 23:18:28 2003
by JoergHeinicke

- ** Added [EndorsedLibsProblem] - how to solve the Xalan problems with JDK 1.4 ''--[SylvainWallez]''
+ ** Added [EndorsedLibsProblem] and [NoMoreDtmIdError] - how to solve the Xalan problems
with JDK 1.4 ''--[SylvainWallez]''
?                              +++++++++++++++++++++++

+ * May 21, 2003
+ ** Cocoon Team is proud to [announce|http://marc.theaimsgroup.com/?l=xml-cocoon-dev&m=105351217629273&w=2]
__Cocoon 2.1 M2__ release! [Get it from new download location|http://cocoon.apache.org/mirror.cgi]...

- ** Cocoon Team is proud to [announce|http://marc.theaimsgroup.com/?l=xml-cocoon-users&m=105160986321558&w=2]
__Cocoon 2.1 M1__ release! [Get it from old download location|http://xml.apache.org/cocoon/dist/]...
Thanks to Carsten for getting it out. ''-- [Vadim]''


Page: http://wiki.cocoondev.org/Wiki.jsp?page=NoMoreDtmIdError , version: 12 on Tue Jun  3
23:07:41 2003 by JoergHeinicke

- First make sure that you __do__ use the version you expect to use. It's not as easy as you
maybe think, because it's not a simple classpath issue. You must force the JVM to load your
version of the JARs before the JDK's one. Read more about it in the Xalan [FAQ|http://xml.apache.org/xalan-j/faq.html#jdk14].\\
+ First make sure that you __do__ use the version you expect to use. You can do this simply
by running a transformation using the [environment check stylesheet|http://xml.apache.org/xalan-j/faq.html#environmentcheck].
If in the output another version is shown as expected (especially 2.2.D11), you have a problem
;-)\\
+ \\
+ It's not as easy to solve as you may think, because it's not a simple classpath issue. You
must force the JVM to load your version of the classes before the JDK's one. Read more about
it in the Xalan [FAQ|http://xml.apache.org/xalan-j/faq.html#jdk14] and at Sylvain's excellent
explanation of the ''infamous [Endorsed Libs Problem]''.\\
- You have the following options:
? ^

+ In short you have the following options:
? ^^^^^^^^^^

+ * use the ParanoidCocoonServlet
- Second simplify and optimize your stylesheets. XPath expressions like {{//*}} or {{<xsl:number
level="any"/>}} force Xalan to store the whole document in the memory. With big documents
(in the [sample|http://marc.theaimsgroup.com/?l=xml-cocoon-users&m=105355235413182&w=2]
2 MB were mentioned) this can lead to the exception. In this sample {{<xsl:number/>}}
could simply be replaced by {{<xsl:value-of select="position()"/>}}.
? ^    ^

+ If you have at the end the correct Xalan version in use, but the error still occurs, simplify
and optimize your stylesheets. XPath expressions like {{//*}} or {{<xsl:number level="any"/>}}
force Xalan to load/store the whole document in the memory. With big documents (in the [sample|http://marc.theaimsgroup.com/?l=xml-cocoon-users&m=105355235413182&w=2]
2 MB were mentioned) this can lead to the exception. In this sample {{<xsl:number/>}}
could simply be replaced by {{<xsl:value-of select="position()"/>}}.
? ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^  +++++++++++++  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^   
                                                                                         
                          +++++

- !! See Also
- * [EndorsedLibsProblem]
- 


Page: http://wiki.cocoondev.org/Wiki.jsp?page=XPatchTaskUsage , version: 1 on Tue Jun  3 23:00:59
2003 by GeoffHoward

New page created:
+ This page will focus on the basics of the <xpatch> task in general.  Another [page|CustomConfigTarget]
will give practical advice on how the build's use of this tag can help you keep your configuration
customizations separate from the Cocoon source tree, and provide separate configurations for
your different environments or projects.
+ 
+ What is the xpatch task?  The javadoc has this (and only this) to say: "Ant task to patch
xmlfiles."  Here's a little more definition:
+ 
+ Basics
+ {{{<xpatch file="${build.webapp}/welcome.xml"
+             srcdir="${documentation}" 
+             includes="**/*.xwelcome"/> }}}
+ 


Page: http://wiki.cocoondev.org/Wiki.jsp?page=YourCocoonBasedProject , version: 4 on Tue Jun
 3 23:03:50 2003 by GeoffHoward

+ __NB: I have tested this and looked at the code, and don't think this works.__ ([GeoffHoward])
+ 



Mime
View raw message