cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alfred Nathaniel (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COCOON-2366) XSP block doesn't compile with Java 8
Date Thu, 21 Feb 2019 16:19:00 GMT

    [ https://issues.apache.org/jira/browse/COCOON-2366?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16774251#comment-16774251
] 

Alfred Nathaniel commented on COCOON-2366:
------------------------------------------

Committed fix to 2.1.13-dev.
http://svn.apache.org/viewvc?view=revision&revision=1853873


> XSP block doesn't compile with Java 8
> -------------------------------------
>
>                 Key: COCOON-2366
>                 URL: https://issues.apache.org/jira/browse/COCOON-2366
>             Project: Cocoon
>          Issue Type: Improvement
>          Components: Blocks: XSP
>    Affects Versions: 2.1.12
>            Reporter: Alfred Nathaniel
>            Priority: Major
>             Fix For: 2.1.13
>
>
> Cocoon 2.1.12 provides as option to use the JDK compiler for XSPs.  The Javac class calls
internal APIs no longer available in recent Java versions.  Since Java 6 the standard API
javax.tool.JavaCompiler is provided.
> Source code to compile with Java 5 and Java 6 would need to do indirect class loading
calls.  Better to drop Java 5 support in Cocoon and declare 1.6 to be the minimum version,



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message