cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alfred Nathaniel (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COCOON-2363) Update to poi-3.14
Date Thu, 21 Feb 2019 15:30:00 GMT

    [ https://issues.apache.org/jira/browse/COCOON-2363?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16774179#comment-16774179
] 

Alfred Nathaniel commented on COCOON-2363:
------------------------------------------

Commited fix to 2.1.13-dev, including updates to

* commons-logging-1.2
* log4j-1.2.17
* commons-codec-1.10.jar
* curvesapi-1.06.jar
* poi-3.14.jar
* poi-ooxml-3.14.jar
* poi-ooxml-schemas-3.14.jar
* xmlbeans-3.0.2.jar
* slf4j-log4j12-1.6.4.jar

http://svn.apache.org/viewvc?view=revision&revision=1853823
http://svn.apache.org/viewvc?view=revision&revision=1853975


> Update to poi-3.14
> ------------------
>
>                 Key: COCOON-2363
>                 URL: https://issues.apache.org/jira/browse/COCOON-2363
>             Project: Cocoon
>          Issue Type: Improvement
>          Components: Blocks: POI
>    Affects Versions: 2.1.12
>            Reporter: Alfred Nathaniel
>            Priority: Major
>             Fix For: 2.1.13
>
>
> The Cocoon 2.1.12 POI block uses poi-3.10-final which contains a few security issues.
> Updating to 3.14 is low-hanging fruit, except that minimum Java is 1.6.  (3.15 drops
deprecated methods.  4.0 raises Java to 1.8).



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message