cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathaniel, Alfred" <Alfred.Nathan...@six-group.com>
Subject RE: Re: About recent commits to 2_1_X
Date Thu, 21 Feb 2019 11:09:42 GMT
Minimum Java version is now 1.6.
That's the version needed for POI 3.14.
It also solves a (mainly academic) issue in the XSP block.

Still the question whether we shouldn't go straight to 1.8.
It's frustrating to develop and then fail the build on Jenkins.
I doubt that anyone bothering to upgrade Cocoon wouldn't want to go to a more recent JDK.

Cheers, Alfred.

-----Original Message-----
From: Cédric Damioli <cdamioli@apache.org> 
Sent: Mittwoch, 20. Februar 2019 19:56
To: dev@cocoon.apache.org
Subject: [External Sender] Re: About recent commits to 2_1_X

I'm a bit lost here :)

After your recent commits, what is now the minimum Java version : 1.5, 
1.6, 1.8 ?

Cédric


Le 19/02/2019 à 12:25, Nathaniel, Alfred a écrit :
> Thanks, it was quite a long shot to develop on Java 8 and then Jenkins on 1.5.
>
> -----Original Message-----
> From: Francesco Chicchiriccò <ilgrosso@apache.org>
> Sent: Dienstag, 19. Februar 2019 12:10
> To: dev@cocoon.apache.org
> Subject: [External Sender] Re: About recent commits to 2_1_X
>
> FYI I have just updated the job to run with JDK 1.6 (it used to be 1.5).
>
> Now it seems to be back working, cool!
>
> Regards.
>
> On 19/02/19 11:36, Nathaniel, Alfred wrote:
>> Yes, that's me although I don't know this error came into being.
>> Must be a time bomb set off by a deeper recompile.
>> I'll put in a fix.
>>
>> Cheers, Alfred.
>>
>> -----Original Message-----
>> From: Francesco Chicchiriccò <ilgrosso@apache.org>
>> Sent: Dienstag, 19. Februar 2019 08:42
>> To: dev@cocoon.apache.org
>> Subject: [External Sender] About recent commits to 2_1_X
>>
>> Hi guys,
>> glad to see some activity raising again in the old roots for 2_1_X;
>> please take care of what Jenkins says about that:
>>
>> https://builds.apache.org/view/A-D/view/Cocoon/job/Cocoon%202.1.X/
>>
>> Recent builds seem to fail due to error
>>
>> compile-core:
>> Compiling 461 source files to
>> /home/jenkins/jenkins-slave/workspace/Cocoon
>> 2.1.X/BRANCH_2_1_X/build/cocoon/classes
>> /home/jenkins/jenkins-slave/workspace/Cocoon
>> 2.1.X/BRANCH_2_1_X/src/java/org/apache/cocoon/components/flow/javascript/fom/FOM_JavaScriptInterpreter.java:665:
>> unreported exception org.apache.regexp.RESyntaxException; must be caught
>> or declared to be thrown
>>        REProgram encodingRE = new
>> RECompiler().compile("^.*encoding\\s*=\\s*([^\\s]*)");
>>                                                      
^
>> Note: Some input files use or override a deprecated API.
>> Note: Recompile with -Xlint:deprecation for details.
>> Note: Some input files use unchecked or unsafe operations.
>> Note: Recompile with -Xlint:unchecked for details.
>> 1 error
>>
>> BUILD FAILED
>> /home/jenkins/jenkins-slave/workspace/Cocoon
>> 2.1.X/BRANCH_2_1_X/tools/targets/compile-build.xml:68: The following
>> error occurred while executing this line:
>> /home/jenkins/jenkins-slave/workspace/Cocoon
>> 2.1.X/BRANCH_2_1_X/tools/targets/compile-build.xml:51: Compile failed;
>> see the compiler error output for details.
>>
>> I have also re-enabled notifications to cvs@cocoon.apache.org, hope it's
>> working now.
>>
>> Regards.
>>

-- 
Cédric Damioli
CMS - Java - Open Source
www.ametys.org


The content of this e-mail is intended only for the confidential use of the person addressed.

If you are not the intended recipient, please notify the sender and delete this email immediately.
Thank you.
Mime
View raw message