cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KuiLIU (JIRA)" <>
Subject [jira] [Created] (COCOON-2360) Inconsistent method names
Date Sun, 22 Apr 2018 08:27:00 GMT
KuiLIU created COCOON-2360:

             Summary: Inconsistent method names
                 Key: COCOON-2360
             Project: Cocoon
          Issue Type: Improvement
          Components: Blocks: (Undefined)
            Reporter: KuiLIU

The following method is named as "select".
"select" is prone to mean that something will be selected.
But this method actually checks whether the expression is contained or not.
So, rename it as "contains" should be more clearly and intuitively.

    public boolean select( String expression ) {
        return this.set.contains( expression );

This message was sent by Atlassian JIRA

View raw message