cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francesco Chicchiriccò <ilgro...@apache.org>
Subject Re: [DISCUSS] Set minimum JDK version to 1.5 for Cocoon 2.1
Date Sat, 08 Oct 2016 11:14:46 GMT
Wow, did not expect this...
To be clear, are you proposing to move to 1.8 the binary AND source compatibility?

Even wilder: how would you see moving the 2_1_X branch to GIT with github integration, thus
allowing us accepting pull requests?

We'll definitely need some help here...
Regards.

Il 8 ottobre 2016 06:43:06 CEST, David Crossley <crossley@apache.org> ha scritto:
>I agree. It should also enable better participation at both Cocoon
>and at Apache Forrest. There were also many supporting products
>that could then be updated. Lets go to 8.
>
>-David
>
>Insight 49 wrote:
>> +1, and I strongly agree with Alfred.
>> 
>> Cocoon 2.1 is a good stable platform, but doesn't encourage new
>> participation, partly I suspect, because many people and businesses
>> run Java 8 or 7 (as you know, you get all kinds of build errors when
>> trying to build cocoon using those Java versions).
>> 
>> If we can upgrade the code, classes and supporting jars, I'd
>recommend
>> Java version 7 or 8.
>> 
>> As an example, the very successful Apache Solr search uses Java 8!
>> 
>> "You will need the Java Runtime Environment (JRE) version 1.8 or
>higher."
>> https://cwiki.apache.org/confluence/display/solr/Installing+Solr
>> 
>> Dan
>> 
>> 
>> On 10/7/16, Nathaniel, Alfred <Alfred.Nathaniel@six-group.com> wrote:
>> > +1 but I would go straight to 6, 7, or even 8.
>> > Past experience is that it is a real nuisance trying to support an
>ancient
>> > JDK no developer is actually using anymore.
>> >
>> > Cheers, Alfred.
>> >
>> > -----Original Message-----
>> > From: Francesco Chicchiriccò [mailto:ilgrosso@apache.org]
>> > Sent: Freitag, 7. Oktober 2016 11:46
>> > To: dev@cocoon.apache.org
>> > Subject: [DISCUSS] Set minimum JDK version to 1.5 for Cocoon 2.1
>> >
>> > Hi all,
>> > as recently noticed during the (unfortunately rejected) patch for
>> > COCOON-2354 [1], it might make sense to upgrade the current minimum
>JDK
>> > requirement for Cocoon 2.1 from 1.4 to 1.5, mainly to ease some
>upgrades
>> > and help Cocoon 2.1 living in the modern world.
>> >
>> > Besides 3rd part library updates, some work could be needed to
>upgrade
>> > our Java code, so help would be appreciated.
>> 


-- 
Francesco Chicchiriccò

Tirasa - Open Source Excellence
http://www.tirasa.net/

Member at The Apache Software Foundation Syncope, Cocoon, Olingo, CXF, OpenJPA, PonyMail
http://home.apache.org/~ilgrosso/

Mime
View raw message