cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francesco Chicchiriccò <ilgro...@apache.org>
Subject Re: [DISCUSS] Set minimum JDK version to 1.5 for Cocoon 2.1
Date Tue, 11 Oct 2016 06:39:31 GMT
On 10/10/2016 19:28, Antonio Gallardo wrote:
> Hi folks,
>
> +1 for 1.5.
>
> If in the future we have the need to move to a more recent version (ie:
> because a patch), then we should discuss it.

Hi,
we *are* discussing exactly that.

At the moment we have a couple of patches on hold, for COCOON-2354 and 
COCOON-2352.

Since it seems to me that there is enough consensus to move on, I will 
open a new issue for setting the compatibility to JDK 1.5 (at least for 
the moment) so that we can move on and accept the two patches above.

Regards.

> On 07/10/16 03:46, Francesco Chicchiriccò wrote:
>> Hi all,
>> as recently noticed during the (unfortunately rejected) patch for
>> COCOON-2354 [1], it might make sense to upgrade the current minimum
>> JDK requirement for Cocoon 2.1 from 1.4 to 1.5, mainly to ease some
>> upgrades and help Cocoon 2.1 living in the modern world.
>>
>> Besides 3rd part library updates, some work could be needed to upgrade
>> our Java code, so help would be appreciated.
>>
>> WDYT?
>> Regards.
>>
>> [1] https://lists.apache.org/thread.html/c03a2390ddd45b801a25e9946a492766936528700000f4f4fbe732d8@%3Cdev.cocoon.apache.org%3E

-- 
Francesco Chicchiriccò

Tirasa - Open Source Excellence
http://www.tirasa.net/

Member at The Apache Software Foundation
Syncope, Cocoon, Olingo, CXF, OpenJPA, PonyMail
http://home.apache.org/~ilgrosso/


Mime
View raw message