cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hans-Heinrich Braun <hansheinrichbr...@yahoo.de>
Subject Re: error in jetty with 3.0.0-beta-1-SNAPSHOT
Date Sat, 13 Feb 2016 10:54:13 GMT
when i do what you told  i get by jetty:run the following error:
[ERROR] [ERROR] Some problems were encountered while processing the POMs:[ERROR] 'dependencies.dependency.version'
for org.aspectj:aspectjrt:jar is missing. @ line 93, column 20 @ [ERROR] The build could
not read 1 project -> [Help 1]org.apache.maven.project.ProjectBuildingException: Some problems
were encountered while processing the POMs:[ERROR] 'dependencies.dependency.version' for org.aspectj:aspectjrt:jar
is missing. @ line 93, column 20
 at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:422) at
org.apache.maven.graph.DefaultGraphBuilder.collectProjects(DefaultGraphBuilder.java:419) at
org.apache.maven.graph.DefaultGraphBuilder.getProjectsForMavenReactor(DefaultGraphBuilder.java:410)
at org.apache.maven.graph.DefaultGraphBuilder.build(DefaultGraphBuilder.java:83) at org.apache.maven.DefaultMaven.buildGraph(DefaultMaven.java:491)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:219) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106) at org.apache.maven.cli.MavenCli.execute(MavenCli.java:862)
at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:286) at org.apache.maven.cli.MavenCli.main(MavenCli.java:197)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at
java.lang.reflect.Method.invoke(Method.java:498) at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229) at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)[ERROR]   [ERROR]
  The project com.mycompany:mysite:1.0-SNAPSHOT (/home/braun/cocoon/mysite/pom.xml) has 1
error[ERROR]     'dependencies.dependency.version' for org.aspectj:aspectjrt:jar is missing.
@ line 93, column 20[ERROR] [ERROR] [ERROR] For more information about the errors and possible
solutions, please read the following articles:[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException


      Von: Francesco Chicchiriccò <ilgrosso@apache.org>
 An: dev@cocoon.apache.org 
 Gesendet: 16:39 Freitag, 12.Februar 2016
 Betreff: Re: error in jetty with 3.0.0-beta-1-SNAPSHOT
   
 On 12/02/2016 16:02, Hans-Heinrich Braun wrote:
  
  i have a cocoon application which i used already some time. When i tried to reinstall it
and tried to start it with jetty:run i get the following error.:  
 
 Hi,
 I have just fixed some problems with published SNAPSHOT artifacts.
 
 I have just re-generated an empty Cocoon 3 block with
 
 mvn archetype:generate \
     -DarchetypeGroupId=org.apache.cocoon.archetype-block \
     -DarchetypeArtifactId=cocoon-archetype-block \
     -DarchetypeVersion=3.0.0-beta-1-SNAPSHOT \
     -DgroupId=com.mycompany \
     -DartifactId=mysite \
    -DarchetypeRepository=https://repository.apache.org/content/repositories/snapshots/
 
 then
 
 cd mysite
 mvn jetty:run
 
 and it worked flawlessly.
 
 I have noticed troubles in building Cocoon 3 source with JDK 8, so I had to switch to JDK
7.
 
 HTH
 Regards.
 
 
  [ERROR] Failed startup of contextorg.mortbay.jetty.plugin.Jetty6PluginWebAppContext@3c3562c0{/,/home/braun/appfuse/braunimmobilien/cocoon/target/rcl/webapp}
java.lang.RuntimeException: Cannot invoke listener org.springframework.web.context.ContextLoaderListener@6468904c

  and later 
  
  Caused by: org.springframework.beans.factory.BeanDefinitionStoreException: Unable to read
spring configurations from classpath*:META-INF/cocoon/spring; nested exception is org.springframework.beans.factory.parsing.BeanDefinitionParsingException:
Configuration problem: Unexpected failure during bean definition parsing Offending resource:
URL[jar:file:/home/braun/.m2/repository/org/apache/cocoon/cocoon-jnet/1.2.2/cocoon-jnet-1.2.2.jar!/META-INF/cocoon/spring/cocoon-jnet-collector.xml]
Bean 'org.apache.cocoon.jnet.URLHandlerFactoryCollector'; nested exception is java.lang.NoSuchMethodError:org.springframework.util.ClassUtils.forName(Ljava/lang/String;)Ljava/lang/Class;

  I could not find out what i made wrong.  
 -- 
Francesco Chicchiriccò

Tirasa - Open Source Excellence
http://www.tirasa.net/

Involved at The Apache Software Foundation:
member, Syncope PMC chair, Cocoon PMC, Olingo PMC, CXF committer
http://home.apache.org/~ilgrosso/ 

  
Mime
View raw message