cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriel Gruber <Gabriel.Gru...@workflow.at>
Subject Cocoon 2.2 with Java 8 and Spring Framework 4.2?
Date Fri, 23 Oct 2015 16:05:49 GMT
Hello Cocooners!

Are there still some people using cocoon in a production application?  We 
still use it in our standard product and now have the challenge to migrate 
to java 1.8 and spring framework 4.2.

While this gives us a few issues to solve in terms of migrating code 
relying on spring 3, we now face the challenge that we have to touch 
cocoon again. As cocoon 2.2 heavily relies on spring, I wondered if anyone 
of you guys has also ready tried to upgrade cocoon 2.2 to spring 4.2 (and 
implicitly also to java 1.8 - also with JDK 1.8 bytecode compatibility 
turned on).

While the trunk of cocoon (2.2) still uses officially spring 2.5.5 it 
actually runs without problems also with latest 3.2.x of spring. But never 
tried with spring 4.x so far and according to our first tries with our 
product I assume there could be some more (heavy) issues, because minimum 
requirements to list of supported libraries has changed quite a bit.

https://github.com/spring-projects/spring-framework/wiki/Migrating-from-earlier-versions-of-the-spring-framework

As an example the Cocoon Spring Configurator needed some small changes, as 
it was not compiling against Spring 4.2. Other projects I have not tried 
so far.

Is there an interest in the community to make this changes in the trunk?

Mit freundlichen GrĂ¼ssen / Best regards,

Gabriel Gruber
Workflow EDV GmbH
Mime
View raw message