cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gabriel Gruber (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COCOON-2347) Make Cocoon 2.2 compatible with latest Spring Framework 4.2.x version
Date Tue, 27 Oct 2015 13:04:27 GMT

    [ https://issues.apache.org/jira/browse/COCOON-2347?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14976335#comment-14976335
] 

Gabriel Gruber commented on COCOON-2347:
----------------------------------------

The alternative of making the subproject cocoon-spring-configurator branch on a cocoon parent
would be to set the spring-version locally, like this:

{code:xml}
  <properties>
    <docs.name>Cocoon Spring Configurator</docs.name>
    <docs.version>2.2.1</docs.version>
    <docs.urlRelativizer>../../../../../</docs.urlRelativizer>    

    <slf4j.version>1.7.0</slf4j.version>
    <logback.version>1.0.7</logback.version>
    <spring-version>4.2.2.RELEASE</spring-version>
  </properties>

  <dependencies>
    <dependency>
      <groupId>org.apache.cocoon</groupId>
      <artifactId>cocoon-configuration-api</artifactId>
      <version>1.0.4</version>
    </dependency>
    <dependency>
      <groupId>commons-io</groupId>
      <artifactId>commons-io</artifactId>
    </dependency>
    
    <dependency>
      <groupId>javax.servlet</groupId>
      <artifactId>servlet-api</artifactId>
      <scope>provided</scope>
    </dependency>
    <dependency>
      <groupId>org.springframework</groupId>
      <artifactId>spring-core</artifactId>
      <version>${spring-version}</version>
    </dependency>
    <dependency>
      <groupId>org.springframework</groupId>
      <artifactId>spring-context</artifactId>
      <version>${spring-version}</version>
    </dependency>
    <dependency>
      <groupId>org.springframework</groupId>
      <artifactId>spring-beans</artifactId>
      <version>${spring-version}</version>
    </dependency>
    <dependency>
      <groupId>org.springframework</groupId>
      <artifactId>spring-aop</artifactId>
      <version>${spring-version}</version>
    </dependency>
    <dependency>
      <groupId>org.springframework</groupId>
      <artifactId>spring-web</artifactId>
      <version>${spring-version}</version>
    </dependency>
{code}

> Make Cocoon 2.2 compatible with latest Spring Framework 4.2.x version
> ---------------------------------------------------------------------
>
>                 Key: COCOON-2347
>                 URL: https://issues.apache.org/jira/browse/COCOON-2347
>             Project: Cocoon
>          Issue Type: Improvement
>          Components: * Cocoon Core, - Components: Sitemap, - Expression language, - Servlet
service framework
>    Affects Versions: 2.2
>            Reporter: Gabriel Gruber
>         Attachments: AbstractElementParser.java.patch, BeanMapElementParser.java.patch,
WildcardBeanMap.java.patch
>
>
> The goal of this ticket is to make the current Cocoon TRUNK of 2.2 compatible with latest
Spring Framework version.
> According to research and feedback in mailinglist following projects (maven modules)
are affected:
> - cocoon-spring-configurator
> - cocoon-sitemap-impl
> - cocoon-servlet-service-impl
> - cocoon-expression-api
> - cocoon-expression-language-impl
> ..
> Let's discuss problems, and append patches here and someone of the committers can then
apply them to SVN.
> Original mail thread: http://markmail.org/message/kkdxrsjqoan6mhr6



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message