cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francesco Chicchiriccò <ilgro...@apache.org>
Subject Re: Cocoon 2.2 with Java 8 and Spring Framework 4.2?
Date Mon, 26 Oct 2015 14:37:00 GMT
On 26/10/2015 15:29, Leszek Gawron wrote:
>
>
>     Hi Gabriel,
>     I do run actually few Cocoon instances in production, but that's
>     3.0.0(-beta-1-SNAPSHOT...). I used to run Cocoon 2.1.X as well.
>
>     Unfortunately, I am not very confident with 2.2, but if you would
>     like to provide some patches against Spring Configurator [1] or
>     any other component to bring them to latest Spring version, I
>     would be happy to review and handle your contribution(s).
>
>     Please be sure to review our contribution docs[2].
>
>
> I am successfully running spring 4.0.6 with cocoon 2.2 in production.
>
> I had to patch:
> - cocoon-pipeline-impl
> - cocoon-servlet-service-impl
> - cocoon-sitemap-impl
>
> anything higher in spring version fails. I do not recall the actual 
> problems but they were deep in cocoon internals and I was unable to 
> debug it properly.
>
> I have not been commiting those to cocoon repo as I have too little 
> knowledge how these changes might affect cocoon overall. I could 
> create a branch and commit my changes for someone more experienced 
> than me.
>
> WDYT?

Hum, is there anyone around with enough know-how about 2.2.?

-- 
Francesco Chicchiriccò

Tirasa - Open Source Excellence
http://www.tirasa.net/

Involved at The Apache Software Foundation:
member, Syncope PMC chair, Cocoon PMC, Olingo PMC
http://people.apache.org/~ilgrosso/


Mime
View raw message