cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Chávez <ccha...@agssa.net>
Subject cocoon 2.1.x and java 8
Date Wed, 07 Jan 2015 23:12:50 GMT
Hi all.

I'm trying to run cocoon in java 8, I found an issue with the JDT core
that did not recognize java 8, the version in cocoon is

lib/core/jdtcore-3.1.0.jar


I did tried updating that version, what I did was copy the file
org.eclipse.jdt.core_3.10.0.v20140902-0626.jar from my Eclipse Luna
Installation and it works.

I did not find a public repository to download the jtdcore jar, I
searched in maven repos and did not find any updated jar.

When I compile and run cocoon with java 8, i found the issue testing the
sample http://localhost:8888/samples/blocks/xsp/java/cacheable which it
throw a NullPointerException when it tried to compile the XPS.

With that version the exception is gone and the page is generated.

thoughts, please ?

-- 
Saludos.
Carlos Chávez.
AG Software, S.A.

Mime
View raw message