cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COCOON-2341) Use ImageIO instead of old com.sun.image.* package in ImageReader
Date Sun, 16 Mar 2014 13:11:44 GMT

    [ https://issues.apache.org/jira/browse/COCOON-2341?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13937134#comment-13937134
] 

Hudson commented on COCOON-2341:
--------------------------------

SUCCESS: Integrated in Cocoon 2.1.X #95 (See [https://builds.apache.org/job/Cocoon%202.1.X/95/])
[COCOON-2341] Applying provided patches (ilgrosso: http://svn.apache.org/viewvc/?view=rev&rev=1573201)
* /cocoon/branches/BRANCH_2_1_X/src/blocks/captcha/java/org/apache/cocoon/reading/CaptchaReader.java
* /cocoon/branches/BRANCH_2_1_X/src/blocks/captcha/samples/sitemap.xmap
* /cocoon/branches/BRANCH_2_1_X/src/java/org/apache/cocoon/reading/ImageReader.java


> Use ImageIO instead of old com.sun.image.* package in ImageReader
> -----------------------------------------------------------------
>
>                 Key: COCOON-2341
>                 URL: https://issues.apache.org/jira/browse/COCOON-2341
>             Project: Cocoon
>          Issue Type: Improvement
>          Components: * Cocoon Core
>    Affects Versions: 2.1.12
>            Reporter: Reynaldo Porras
>            Assignee: Francesco Chicchiriccò
>             Fix For: 2.1.13
>
>         Attachments: COCOON-2341.patch, COCOON-CaptchaReader-2341.patch, COCOON-CaptchaReader-sample-sitemap-2341.patch
>
>
> Classes from  sun.* should not be used as specified in:
> http://www.oracle.com/technetwork/java/faq-sun-packages-142232.html
> ImageIO is available since java 1.4. I have tested it using java 1.4  version and it
works. This change has already be implemented in cocoon 2.2.1 version as in: https://issues.apache.org/jira/browse/COCOON-2327
> I have a patch which is pretty much the same as the one in COCOON-2327 only differences
are that import of SystemUtils is removed and It is not using generics to keep compatibility
with java 1.4.
> Additionally this change allows cocoon-core 2.1.13-dev to compile in java 1.7



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message