cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francesco Chicchiriccò (JIRA) <j...@apache.org>
Subject [jira] [Commented] (COCOON-2341) Use ImageIO instead of old com.sun.image.* package in ImageReader
Date Thu, 20 Feb 2014 08:05:20 GMT

    [ https://issues.apache.org/jira/browse/COCOON-2341?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13906737#comment-13906737
] 

Francesco Chicchiriccò commented on COCOON-2341:
------------------------------------------------

Without your patch, building with JDK 7 fails and JDK 6 succeeds with warnings.

With your patch, building with JDK 6 runs smoothly while with JDK 7 the following exception
is returned (I am building with all blocks):

Compiling 45 source files to /home/ilgrosso/work/cocoon/2_1_X/build/cocoon/blocks/databases/dest
/home/ilgrosso/work/cocoon/2_1_X/src/blocks/databases/java/org/apache/cocoon/databases/ibatis/ExcaliburDataSourceFactory.java:82:
error: DataSourceWrapper is not abstract and does not override abstract method getParentLogger()
in CommonDataSource
    protected static final class DataSourceWrapper implements DataSource {


> Use ImageIO instead of old com.sun.image.* package in ImageReader
> -----------------------------------------------------------------
>
>                 Key: COCOON-2341
>                 URL: https://issues.apache.org/jira/browse/COCOON-2341
>             Project: Cocoon
>          Issue Type: Improvement
>          Components: * Cocoon Core
>    Affects Versions: 2.1.12
>            Reporter: Reynaldo Porras
>         Attachments: COCOON-2341.patch
>
>
> Classes from  sun.* should not be used as specified in:
> http://www.oracle.com/technetwork/java/faq-sun-packages-142232.html
> ImageIO is available since java 1.4. I have tested it using java 1.4  version and it
works. This change has already be implemented in cocoon 2.2.1 version as in: https://issues.apache.org/jira/browse/COCOON-2327
> I have a patch which is pretty much the same as the one in COCOON-2327 only differences
are that import of SystemUtils is removed and It is not using generics to keep compatibility
with java 1.4.
> Additionally this change allows cocoon-core 2.1.13-dev to compile in java 1.7



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message