cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robby Pelssers <Robby.Pelss...@nxp.com>
Subject RE: c3: null pointer exception in ResponseHeaderCollector.isModifiedResponse
Date Wed, 28 Mar 2012 08:50:42 GMT
Hi all,

I'm still not sure if you were able to come up  with  the smallest possible test case for
this issue.   I just upgraded Cocoon trunk and did a clean install.  Next I started the cocoon-sample
and I can confirm that invoking following URL's work just fine on my windows 7 64-bit machine:

      <map:match equals="sax-pipeline/simple-2">
        <map:generate src="sax-pipeline/simple-2.xml" />
        <map:serialize />
      </map:match>

http://localhost:8888/sax-pipeline/simple-1


      <map:match pattern="sax-pipeline/simple-xhtml">
        <map:generate src="sax-pipeline/simple.xml" />
        <map:transform src="sax-pipeline/simple.xslt">
          <map:parameter name="myParam" value="2" />
        </map:transform>
        <map:serialize type="xhtml" />
      </map:match>

http://localhost:8888/sax-pipeline/simple-xhtml


      <map:match pattern="expression-language/map-numbers/*">
        <map:generate src="sax-pipeline/{map:1}.xml" />
        <map:serialize type="xml" />
      </map:match>

http://localhost:8888/expression-language/map-numbers/simple

      <map:match pattern="expression-language/jexl">
        <map:generate src="sax-pipeline/{jexl:cocoon.request.fileName}.xml" />
        <map:serialize type="xml" />
      </map:match>

http://localhost:8888/expression-language/jexl?fileName=simple

Robby


From: Javier Puerto [mailto:jpuerto@gmail.com]
Sent: Wednesday, March 28, 2012 10:11 AM
To: dev@cocoon.apache.org
Subject: Re: c3: null pointer exception in ResponseHeaderCollector.isModifiedResponse


El 28 de marzo de 2012 00:14, Thorsten Scherler <scherler@gmail.com<mailto:scherler@gmail.com>>
escribió:
On 03/27/2012 08:47 PM, Lars Huttar wrote:
Thorsten wrote,
Hmm, did actually somebody tried c3 on win before?

I just downloaded the file on a pet project I have and it works without any prob on linux.

So let us do the clean routine: cd $c3_home svn up mvn clean install cd /c3/theParent mvn
clean install cd ethnologue-17-pub/ mvn jetty:run

Does the error persists? I can remember i came in contact with DataStore, when I created a
jms based pipe and did not enter a c3 context, but this is not your case at all.

I don't actually have a $c3_home envt variable - maybe that was just shorthand? I did a svn
up in c:\Program Files\Apache Software Foundation\c3, which is *a* place that I installed
C3. I may have installed it in more than one place, and if so, I don't know which place is
the relevant one. Is there any way to find out? I also did mvn clean install in that directory.

Then I went to theParent (which is not under the folder where I did svn up) and did
mvn clean install
cd ethnologue-17-pub
mvn jetty:run

Yes, the error persists. I get this in the cocoon.log:

...

Javier wrote this morning something that he was on a vm windows and could reproduce the problem.
Need to talk to him when he comes into work. Further I will ask our intern to try on windows.
Really seems to be a problem with windows. Will keep you informed.

I was configuring a windows developer environment on my new laptop until the new Ubuntu LTS
is released when I saw your problem. I've downloaded and tested your application with:

* Windows 7 x64
* Latest Java 1.7
* Maven 3.0.4

I can reproduce the problem from cli but I can't import the project into Eclipse so I didn't
investigate further. The sitemap.xmap looks fine so I have to test the samples block for C3
to check if it's a common problem.

Lars, did you tested the samples block yet? is it working for you?
Thorsten, did you tested the Lars sample in Linux?

Lars, to be easier to download your sample I think that is better if you do a "mvn clean"
first to avoid all the  maven generated stuff also if you create a .zip file with all the
stuff it could be better.


salu2

--
Thorsten Scherler<scherler.at.gmail.com<http://scherler.at.gmail.com>>
codeBusters S.L. - web based systems
<consulting, training and solutions>

http://www.codebusters.es/


Mime
View raw message