Hi all,

 

A few weeks ago we had a discussion [1] whether to increase for Cocoon3 the minimum Java version from 1.5 to 1.6.

There were a number of advantages identified to be gained by using Java6, which I don’t want to repeat here,

 

The only downside is the exclusion of potential C3 users locked in to Java5.

A survey on the user list [2] asking users to step forward if that really applied to anybody did not yield any response.

 

Therefore I’ call the vote on Code Modification [3]:

 

+1 = Yes, Cocoon3 shall require Java 1.6

-1 = No, Cocoon3 must remain usable with Java 1.5 (with justification for the veto)

 

This change is targeted only at Cocoon3.  Cocoon2.1 and Cocoon2.2 are not affected.

 

Please cast your votes before Mon 3 Oct 06:00 UTC.

 

Here is mine:

+1

 

Cheers, Alfred.

 

[1] http://www.mail-archive.com/dev@cocoon.apache.org/msg59791.html

[2] http://www.mail-archive.com/users@cocoon.apache.org/msg46231.html

[3] http://www.apache.org/foundation/voting.html

 

The content of this e-mail is intended only for the confidential use of the person addressed.
If you are not the intended recipient, please notify the sender and delete this e-mail immediately.
Thank you.