cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robby Pelssers" <robby.pelss...@ciber.com>
Subject RE: building the Sample fails after updating from trunk
Date Thu, 07 Jul 2011 08:11:34 GMT

Hi Francesco,

after rebooting my system the build works fine.  I should have tried that before but to get
back into development mode after reboot is a pain-in-the-ass ;-)

Robby

-----Oorspronkelijk bericht-----
Van: Francesco Chicchiriccò [mailto:ilgrosso@apache.org]
Verzonden: do 7-7-2011 7:31
Aan: dev@cocoon.apache.org
Onderwerp: Re: building the Sample fails after updating from trunk
 
On 06/07/2011 19:18, Robby Pelssers wrote:
> Hi all,
>
> I just updated from trunk again and tried to run the tests.
>
> The sample block seems to fail:

Hi Robby,
I've just run all tests (by mean of "mvn clean install -P it,archetypes" 
from root source or it.sh / it.bat), then a specific "mvn clean test" 
from cocoon-sample dir, and everything seems to work fine, at least on 
Linux and Mac OS X.

Your issue seems to be related to something specific of your environment 
(does the message "Access is denied" suggest anything?):

> [...]
> org.apache.cocoon.maven.deployer.monolithic.DeploymentException: Can't deploy 'C
> :\development\workspaces\cocoon\trunk\cocoon-rest\target\classes'.
> [...]
> Caused by: java.io.FileNotFoundException: C:\development\workspaces\cocoon\trunk
> \cocoon-rest\target\classes (Access is denied)
-- 
Francesco Chicchiriccò

Apache Cocoon Committer and PMC Member
http://people.apache.org/~ilgrosso/



Mime
View raw message