cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Huib Verwey <Huib.Ver...@mpi.nl>
Subject Building Cocoon + using blocks from cocoon-block-modules without SNAPSHOT versions.
Date Thu, 09 Jun 2011 16:35:59 GMT
Hi,

I'm trying to build Cocoon 2.2 SVN version with an empty Maven repository on my machine. It
does not build, there are some daisy dependencies that cannot be downloaded from anywhere
and there are wrong version numbers for Cocoon's own subprojects.

Can somebody fix this situation? It is not only very inconvenient but also a rather embarrassing,
newcomers to Cocoon will quickly give up, which is a shame.

Also, I'd like to be able to use some blocks which are still classified as -SNAPSHOT even
though they are perfectly useable. Preferably I would like all the blocks from the blocks
folder (that are reasonably stable) to be downloadable from an external repository. Because
the modules do not have a non-SNAPSHOT version they are not in any repo afaik and I am forced
to build cocoon from the source, which gives me the above mentioned troubles.

I appreciate that all the developers have left for Cocoon 3, but please, this is really bad
advertising for Cocoon, so please please fix it. As long as there is no shiny Cocoon 3, most
people will use Cocoon 2.2 and some people will try to build it from source, if only for the
extra modules.

Thanks,

Huib.

--
Drs. Huib Verweij
Senior software developer - The Language Archive
Max Planck Institute for Psycholinguistics
P.O. Box 310
6500 AH Nijmegen
The Netherlands
t +31-24-3521911
e huib.verwey@mpi.nl<mailto:huib.verwey@mpi.nl>
w http://www.mpi.nl/


Mime
View raw message