cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject State of Cocoon Builds in Gump
Date Tue, 27 Jul 2010 06:48:28 GMT
Hi,

we've been building a large part of Cocoon 3 and almost everything Lenya
and Coccoon3 need of Cocoon 2.2 for weeks now.

Some tests failed initially because Xalan's trunk now requires
serializer.jar but I managed to fix that by sneaking in Xalan 2.7.1's
POM when Cocoon asks for it so that Cocoon gets serializer.jar via a
transitive dependency.  If you ever upgrade your Xalan dependencies you
will likely add the dependency on serializer anyway.

The one remaining failure I can see is in flowscript-impl and this is
due to a backwards incompatible change to the continuation API in rhino
between 1.7R1 and 1.7R2 AFAICT.  I guess you already know about that.

Before I start to fiddle with Gump's config so that Cocoon does not see
rhino's trunk I wanted to ask whether there were any plans to migrate to
the newer continuation API (in which case I wouldn't need to hide
rhino).

BTW, let me know if you want to enable nagging.

Cheers

        Stefan

Mime
View raw message