cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Laurent Medioni" <lmedi...@odyssey-group.com>
Subject Cocoon 2.1.11- XSP compiled in Java 1.3 when running Cocoon with a 1.6 JVM and using the Eclipse compiler
Date Fri, 21 Aug 2009 15:27:37 GMT
Hello,
Still with our Cocoon 2.1.11 on a 1.6 JVM series...
Just noticed that org.apache.cocoon.components.language.programming.java.EclipseJavaCompiler
does not know anything about 1.6 (nothing wrong with this as it uses JDT 3.1) but in this
case defaults to... 1.3, which is quite a big step back from 1.4 ;).
It is possible to force the compliance level to 1.5 through the xconf parameter compiler-compliance-level
but no configuration is possible for the generated class file compatibility, which does not
obey to the same parameter...

I tried to replace JDT 3.1 by the latest 3.5 and locally patched EclipseJavaCompiler to manage
a 1.6 value... For the moment it works well...

Cheers,
Laurent

____________________________________________________________

 This email and any files transmitted with it are CONFIDENTIAL and intended
  solely for the use of the individual or entity to which they are addressed.
 Any unauthorized copying, disclosure, or distribution of the material within
  this email is strictly forbidden.
 Any views or opinions presented within this e-mail are solely those of the
  author and do not necessarily represent those of Odyssey Financial
Technologies SA unless otherwise specifically stated.
 An electronic message is not binding on its sender. Any message referring to
  a binding engagement must be confirmed in writing and duly signed.
 If you have received this email in error, please notify the sender immediately
  and delete the original.
Mime
View raw message