cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aryanurfriend <vishal.gan...@ubs.com>
Subject Unable to deploy Cocoon 2.2 on WebSphere
Date Thu, 04 Jun 2009 20:51:36 GMT

I have build the Cocoon 2.2 Sample WebApp using Maven (as per the
instructions in Getting Started manual). I created a block with name
formatter and a web app formatterApp. I added the dependency for formatter
in the web app's pom.xml and built the war with maven. When I deploy this
war on Tomcat or Jetty, its working fine but when I deploy the same war on
Websphere it fails with the exception,

Caused by: java.net.MalformedURLException: Could not resolve
blockcontext:/formatter/ due to java.net.MalformedURLException: Unknown
block name formatter in block context uri blockcontext:/formatter/
	at
org.apache.cocoon.servletservice.spring.ServletFactoryBean.init(ServletFactoryBean.java:111)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at
org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeCustomInitMethod(AbstractAutowireCapableBeanFactory.java:1325)
	at
org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1294)
	at
org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1257)
	... 62 more


I tried to change this blockcontext to file:/ but still no luck.

The first thing I would like to ask is, cant we deploy a webapp without
blocks in cocoon 2.2 as we do in earlier versions of cocoon? and what is
this blockcontext is all about?

Early help will be highly appreciated.

Thanks a ton in advance.
-- 
View this message in context: http://www.nabble.com/Unable-to-deploy-Cocoon-2.2-on-WebSphere-tp23877509p23877509.html
Sent from the Cocoon - Dev mailing list archive at Nabble.com.


Mime
View raw message