cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robby Pelssers" <robby.pelss...@ciber.nl>
Subject RE: cocoon 3 archetypes (3.0.0-alpha-1) remark
Date Fri, 15 May 2009 07:36:38 GMT
$ mvn -version
Maven version: 2.0.9
Java version: 1.5.0_16
OS name: "windows xp" version: "5.1" arch: "x86" Family: "windows"

$ java -version
java version "1.5.0_16"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b02)
Java HotSpot(TM) Client VM (build 1.5.0_16-b02, mixed mode, sharing)


I just tried again and now it works.  The only thing I did  yesterday was delete my local
maven repo in order to try to solve some other issues.

Robby




-----Original Message-----
From: Reinhard Pötz [mailto:reinhard@apache.org] 
Sent: Friday, May 15, 2009 12:42 AM
To: dev@cocoon.apache.org
Subject: Re: cocoon 3 archetypes (3.0.0-alpha-1) remark

Robby Pelssers wrote:
> FYI,
> When using the archetypes for cocoon-3,  I noticed that the <version> is
> generated like <version>1-SNAPSHOT</version>.  This is the case for
> parent-archetype and for web and block it does the same for the <parent>
> version.
> 
> Also to be able to use the archetypes I had to modify the version of the
> maven-archetype-plugin to “2.0-alpha-4”, whereas the docs mention
> “1.0-alpha-7”.
> 
> mvn org.apache.maven.plugins:maven-archetype-plugin:2.0-alpha-4:create
> -DarchetypeGroupId=org.apache.cocoon.archetype-block
> -DarchetypeArtifactId=cocoon-archetype-block
> -DarchetypeVersion=3.0.0-alpha-1 -DgroupId=com.mycompany
> -DartifactId=myArtifact

What Maven version do you use?

Following command worked with Maven 2.0.9 / Java 1.6.0_12 fine for me:

mvn org.apache.maven.plugins:maven-archetype-plugin:1.0-alpha-7:create
-DarchetypeGroupId=org.apache.cocoon.archetype-block
-DarchetypeArtifactId=cocoon-archetype-block
-DarchetypeVersion=3.0.0-alpha-1 -DgroupId=com.mycompany
-DartifactId=mysite

-- 
Reinhard Pötz                           Managing Director, {Indoqa} GmbH
                         http://www.indoqa.com/en/people/reinhard.poetz/

Member of the Apache Software Foundation
Apache Cocoon Committer, PMC member                  reinhard@apache.org
________________________________________________________________________
Mime
View raw message