cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alfred Nathaniel <>
Subject Re: FW: Cocoon versions for Java 6
Date Mon, 02 Mar 2009 23:26:51 GMT
Hi Laurent,

we are using Cocoon 2.1.x still with Java 5.
But with that comment in the bug report you should just give it a spin.
If you want to be cautious, define the magic property.
If you feel more adventerous, try it without and fix the source where it

Cheers, Alfred.

Submitted On 25-JUL-2007 
I tripped over this, and thought: JDK6 has broken something.

Now that there is a documented workaround, I think that it could be considered "fixed", as
we now have two options:

1) Add -Dsun.lang.ClassLoader.allowArraySyntax=true if you want to use a library for which
you don't have the source with JDK6

2) Change loader.loadClass( name ) to Class.forName( name, false, loader ) if you own the

If Sun are not intending to fix this to be compatible without the flag, then I think it would
be great if we could have a clear statement here to close off this bug

On Thu, 2009-02-26 at 14:25 +0100, Laurent Medioni wrote:
> Hi,
> Trying my luck on the dev list ?
> Thanks,
> Laurent
> -----Original Message-----
> From: Laurent Medioni [] 
> Sent: mardi, 24. février 2009 10:37
> To:
> Subject: Cocoon versions for Java 6
> Hi,
> Anyone knows if a Cocoon version is validated/intended for Java 6 ?
> Sorry Googled a lot but to no avail...
> We plan to move our 2.1.11 application to Java 6 and already had a nasty Reflection issue
for arrays with 1.6 described in
> And I noticed that there are a lot of occurrences of these calls in 2.1.11...
> Thanks.

View raw message