cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Pieber (JIRA)" <j...@apache.org>
Subject [jira] Created: (COCOON3-27) [PATCH] Add Java5 support
Date Sun, 08 Feb 2009 02:30:59 GMT
[PATCH] Add Java5 support
-------------------------

                 Key: COCOON3-27
                 URL: https://issues.apache.org/jira/browse/COCOON3-27
             Project: Cocoon 3
          Issue Type: Improvement
          Components: cocoon-stax
            Reporter: Andreas Pieber
            Assignee: Cocoon Developers Team
             Fix For: 3.0.0-alpha-2


Kilian pushed me at the fact that we could very easily support java5 in the StAX component.
The only thing which have to be done for this is to add an optional dependency to the woodstox
StAX implementation and remove all the @Override-Annotations from the code. So in a java6
environment the woodstox reference is not required and the module will work with the default
implementation. For java5 the additional dependency is required. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message