cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Grzegorz Kossakowski (JIRA)" <j...@apache.org>
Subject [jira] Created: (COCOON-2236) Servlet Service Framework 1.1.0 is incompatible with Cocoon Core 2.2
Date Wed, 13 Aug 2008 10:50:44 GMT
Servlet Service Framework 1.1.0 is incompatible with Cocoon Core 2.2
--------------------------------------------------------------------

                 Key: COCOON-2236
                 URL: https://issues.apache.org/jira/browse/COCOON-2236
             Project: Cocoon
          Issue Type: Bug
          Components: - Servlet service framework
    Affects Versions: 2.2
            Reporter: Grzegorz Kossakowski
            Assignee: Grzegorz Kossakowski
             Fix For: 2.2


Servlet Service Framework was refactored because there was hidden dependency on CocoonSourceResolver
(in a fact, there was a hidden cyclic dependency) which was of course a bad situation because
SSF is meant to be completely independent from Cocoon.

However, these refactorings introduced some back-incompatibility (which is just a bug). In
order to handle different protocols in context-path property of servlet bean, SSF installs
JNet handlers using AOP from Spring. The problematic part is that this interceptor is disabled
for init() method of every bean, including servlet beans. SitemapServlet does some serious
work in its init() method and requires protocols (like block-context:) to be working properly
so JNet handler must be installed.

The solution for this problem will be to manually install JNet handler in ServletFactoryBean
where init method is called.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message