cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grzegorz Kossakowski <g...@tuffmail.com>
Subject Re: Cocoon-jms-sample requires Java >= 1.5
Date Wed, 30 Jul 2008 13:38:01 GMT
Reinhard Pötz pisze:
> Now we have the problem that the ActiveMQ version that we use was built 
> with Java 5:

<snip/>

> According to 
> http://activemq.apache.org/can-i-use-activemq-5x-or-later-on-java-14.html 
> there is no version built for 1.4.
> 
> What shall we do?

Actually, this is a part of bigger picture. Let me explain.

Due to refactorings in Servlet Service Framework and Spring Configurator (thanks Reinhard
for doing 
that!) they are not back compatible anymore so we will need to release 2.0.0 of both projects.

Now Cocoon Core (of version 2.2.0) depends on these projects so Core itself becomes not back

compatible anymore. Therefore we'll need to release 2.3.0 of Cocoon Core to keep things clean.

Then, if we are going to release 2.3.0 I think it's valid to bump Java version requirement.

Especially if you look at this message from Sun:

J2SE 1.4.2 is in its Java Technology End of Life (EOL) transition period. The EOL transition
period 
began Dec, 11 2006 and will complete October 30th, 2008, when J2SE 1.4.2 will have reached
its End 
of Service Life (EOSL).

[...]

Customers interested in continuing to receive critical fixes, are encouraged to consider the

following options:

     * Migrate to the latest Java SE release
     * Migrate to Java SE for Business 1.4.2

(the source: http://java.sun.com/j2se/1.4.2/download.html)

Then I think the solution is rather clear: we need to migrate to 1.5. If Sun is not supporting
Java 
1.4 then I don't want to support it as well in our _trunk_.

People that need to stick to Java 1.4 still have a choice: We have released 2.2 that works
with Java 
1.4.

Therefore I propose to switch to 1.5 and focus on getting real work done.

WDYT?

-- 
Grzegorz Kossakowski

Mime
View raw message