cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Pötz <reinh...@apache.org>
Subject Re: Cocoon-jms-sample requires Java >= 1.5
Date Wed, 30 Jul 2008 13:37:10 GMT
Felix Knecht wrote:
> Reinhard Pötz schrieb:
>>
>> According to 
>> http://activemq.apache.org/can-i-use-activemq-5x-or-later-on-java-14.html 
>> there is no version built for 1.4.
>>
>> What shall we do?
>>
> Can't we use the enforcer plugin that the jms block is only build and 
> added when using 1.5 or higher and make a note in the docs that jms 
> block needs at least 1.5?

Actually it's the jms-sample module only (we want to use an embedded 
ActiveMQ instance), not the impl.

Having a profile that is activated by a minimum Java version seems to be 
the best idea.

-- 
Reinhard Pötz                           Managing Director, {Indoqa} GmbH
                          http://www.indoqa.com/en/people/reinhard.poetz/

Member of the Apache Software Foundation
Apache Cocoon Committer, PMC member                  reinhard@apache.org
________________________________________________________________________

Mime
View raw message